RESOLVED FIXED 171974
Unify hasTouchScrollableOverflow/needsCompositedScrolling concepts
https://bugs.webkit.org/show_bug.cgi?id=171974
Summary Unify hasTouchScrollableOverflow/needsCompositedScrolling concepts
Frédéric Wang (:fredw)
Reported 2017-05-11 09:14:29 PDT
The following pattern is found in various places: #if PLATFORM(IOS) ...hasTouchScrollableOverflow()... #else ...needsCompositedScrolling()... #endif We can refactor the code to do that in one function. @Simon: I don't know if we can merge these functions a bit further... It seems that to fix bug 149264 we would consider composited scrolling on iOS too?
Attachments
Patch (5.30 KB, patch)
2017-05-11 09:32 PDT, Frédéric Wang (:fredw)
simon.fraser: review+
simon.fraser: commit-queue-
Patch (5.30 KB, patch)
2017-05-11 11:28 PDT, Frédéric Wang (:fredw)
commit-queue: commit-queue-
Patch (5.30 KB, patch)
2017-05-11 11:33 PDT, Frédéric Wang (:fredw)
no flags
Frédéric Wang (:fredw)
Comment 1 2017-05-11 09:32:13 PDT
Michael Catanzaro
Comment 2 2017-05-11 11:10:50 PDT
Comment on attachment 309716 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=309716&action=review > Source/WebCore/rendering/RenderLayer.cpp:2191 > +bool RenderLayer::useCoordinatedScrolling() const Would RenderLayer::usesCoordinatedScrolling be a better name for this?
Frédéric Wang (:fredw)
Comment 3 2017-05-11 11:19:04 PDT
(In reply to Michael Catanzaro from comment #2) > > Source/WebCore/rendering/RenderLayer.cpp:2191 > > +bool RenderLayer::useCoordinatedScrolling() const > > Would RenderLayer::usesCoordinatedScrolling be a better name for this? Right, I think it will be more consistent with the names of other member functions.
Simon Fraser (smfr)
Comment 4 2017-05-11 11:19:36 PDT
Comment on attachment 309716 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=309716&action=review >> Source/WebCore/rendering/RenderLayer.cpp:2191 >> +bool RenderLayer::useCoordinatedScrolling() const > > Would RenderLayer::usesCoordinatedScrolling be a better name for this? Yes! Hopefully this won't be confused with coordinated graphics. Maybe "acceleratedScrolling"?
Frédéric Wang (:fredw)
Comment 5 2017-05-11 11:28:47 PDT
WebKit Commit Bot
Comment 6 2017-05-11 11:30:53 PDT
Comment on attachment 309733 [details] Patch Rejecting attachment 309733 [details] from commit-queue. Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-01', 'validate-changelog', '--check-oops', '--non-interactive', 309733, '--port=mac']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit ChangeLog entry in Source/WebCore/ChangeLog contains OOPS!. Full output: http://webkit-queues.webkit.org/results/3719277
Frédéric Wang (:fredw)
Comment 7 2017-05-11 11:33:26 PDT
Created attachment 309734 [details] Patch Setting correct reviewer...
WebKit Commit Bot
Comment 8 2017-05-11 11:49:34 PDT
Comment on attachment 309734 [details] Patch Clearing flags on attachment: 309734 Committed r216688: <http://trac.webkit.org/changeset/216688>
Frédéric Wang (:fredw)
Comment 9 2017-05-16 07:37:03 PDT
This is fixed.
Note You need to log in before you can comment on or make changes to this bug.