Bug 171743 - [GTK] Warning when GSS auth fails
Summary: [GTK] Warning when GSS auth fails
Status: RESOLVED MOVED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-05 11:57 PDT by Bastien Nocera
Modified: 2017-05-22 05:14 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastien Nocera 2017-05-05 11:57:39 PDT
webkitgtk4-2.16.1-2.fc26.x86_64

May 05 20:53:01 classic WebKitNetworkPr[21509]: Unspecified GSS failure.  Minor code may provide more information: Mutual authentication failed
May 05 20:53:01 classic WebKitNetworkPr[21509]: gsignal.c:2641: instance '0x55b9d1f638e0' has no handler with id '381'
May 05 20:53:01 classic WebKitNetworkPr[21509]: g_signal_handler_disconnect: assertion 'handler_id > 0' failed

NULL/0 checks missing in the error path?
Comment 1 Michael Catanzaro 2017-05-05 13:08:29 PDT
Maybe Tom knows where this code is. Otherwise we'd need a G_DEBUG=fatal-warnings backtrace.
Comment 2 Bastien Nocera 2017-05-06 02:16:35 PDT
(In reply to Michael Catanzaro from comment #1)
> Maybe Tom knows where this code is. Otherwise we'd need a
> G_DEBUG=fatal-warnings backtrace.

I can't reproduce the problem at will, and there are good chances I'd hit another warning before this one.

There are good chances that the error path problem is also the one causing the crash at:
https://bugzilla.gnome.org/show_bug.cgi?id=782239
Comment 3 Tomas Popela 2017-05-14 23:30:12 PDT
(In reply to Bastien Nocera from comment #0)
> webkitgtk4-2.16.1-2.fc26.x86_64
> 
> May 05 20:53:01 classic WebKitNetworkPr[21509]: Unspecified GSS failure. 
> Minor code may provide more information: Mutual authentication failed
> May 05 20:53:01 classic WebKitNetworkPr[21509]: gsignal.c:2641: instance
> '0x55b9d1f638e0' has no handler with id '381'
> May 05 20:53:01 classic WebKitNetworkPr[21509]: g_signal_handler_disconnect:
> assertion 'handler_id > 0' failed
> 
> NULL/0 checks missing in the error path?

I'm aware of the issue Bastien (some of the Red Hat internal sites are triggering it).
Comment 4 Tomas Popela 2017-05-22 01:02:01 PDT
I created a libsoup bug for this issue and attached patch there - https://bugzilla.gnome.org/show_bug.cgi?id=782940