Bug 171568 - check-webkit-style should also keep js-test-post[-async].js in sync
Summary: check-webkit-style should also keep js-test-post[-async].js in sync
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: David Kilzer (:ddkilzer)
URL:
Keywords:
Depends on: 171424
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-02 13:57 PDT by David Kilzer (:ddkilzer)
Modified: 2017-05-02 20:59 PDT (History)
6 users (show)

See Also:


Attachments
Patch v1 (8.31 KB, patch)
2017-05-02 14:01 PDT, David Kilzer (:ddkilzer)
joepeck: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2017-05-02 13:57:25 PDT
check-webkit-style should also keep js-test-post[-async].js in sync after the fix in Bug 171424.

We should also add a test for map_functions_to_dict() in jstest.py since that method relies on a regular expression built out of bailing wire and duct tape to extract the function source out of a JavaScript file.  When it fails, we'll want to add a new test that fails to make it easier to fix.
Comment 1 David Kilzer (:ddkilzer) 2017-05-02 14:01:00 PDT
Created attachment 308850 [details]
Patch v1
Comment 2 Joseph Pecoraro 2017-05-02 14:56:58 PDT
Comment on attachment 308850 [details]
Patch v1

View in context: https://bugs.webkit.org/attachment.cgi?id=308850&action=review

r=me

> Tools/Scripts/webkitpy/style/checkers/jstest_unittest.py:31
> +class JSTestTestCase(unittest.TestCase):

Maybe JSTestCheckerTestCase? I dunno how these things need to be named.
Comment 3 David Kilzer (:ddkilzer) 2017-05-02 19:48:19 PDT
Comment on attachment 308850 [details]
Patch v1

View in context: https://bugs.webkit.org/attachment.cgi?id=308850&action=review

>> Tools/Scripts/webkitpy/style/checkers/jstest_unittest.py:31
>> +class JSTestTestCase(unittest.TestCase):
> 
> Maybe JSTestCheckerTestCase? I dunno how these things need to be named.

I like that better so we don't have ...TestTest... in the name.
(I was cribbing off JSTestCase in js_unittest.py.)
Comment 4 David Kilzer (:ddkilzer) 2017-05-02 20:59:33 PDT
Committed r216110: <http://trac.webkit.org/changeset/216110>