Bug 171555 - REGRESSION(r215555-215557): [GTK] Several performance tests abort with GLib-CRITICAL **: g_source_set_ready_time: assertion 'source->ref_count > 0' failed
Summary: REGRESSION(r215555-215557): [GTK] Several performance tests abort with GLib-C...
Status: RESOLVED DUPLICATE of bug 176806
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-02 10:26 PDT by Carlos Alberto Lopez Perez
Modified: 2017-11-27 02:57 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2017-05-02 10:26:02 PDT
This started to happen on build 199 https://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Perf%29/builds/199

Several tests fail https://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Perf%29/builds/199/steps/perf-test/logs/stdio

Running Canvas/compositing-fillRect.html (34 of 160)
error: Canvas/compositing-fillRect.html
g_source_set_ready_time: assertion 'source->ref_count > 0' failed

FAILED
Finished: 17.294655 s

Running Dromaeo/dom-query.html (58 of 160)
timeout: Dromaeo/dom-query.html
FAILED
Finished: 698.050056 s


Running Dromaeo/jslib-event-jquery.html (68 of 160)
error: Dromaeo/jslib-event-jquery.html
g_source_set_ready_time: assertion 'source->ref_count > 0' failed

FAILED
Finished: 31.161938 s

[...]

The exact tests that fail change from run to run. 



My initial suspect is the GLib/GLib-networking upgrade in r215556 <https://trac.webkit.org/r215556>.
I will try to reproduce it locally and see if I can confirm this.
Comment 1 Carlos Alberto Lopez Perez 2017-06-02 08:23:18 PDT
This got much worse between r217669-r217689

r217669 5 failures : https://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Perf%29/builds/470
r217689 14 failures : https://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release%20%28Perf%29/builds/471


Maybe it was the GTK+ upgrade?

I'm able to reproduce it on my laptop but its hard to reproduce.. I have to run the whole perf test suite and maybe I get one failure like those at the end, not 14 like on the bot.
Comment 2 Yusuke Suzuki 2017-06-04 03:22:46 PDT
Can we know which g_source_set_ready_time causes this assertion?
Comment 3 Carlos Garcia Campos 2017-06-05 00:27:22 PDT
Carlos, would it be possible to run the perf tests with G_DEBUG=fatal-criticals and get a bt?
Comment 4 Michael Catanzaro 2017-11-06 18:57:58 PST
There's one in bug #176806 that might be related. It's not simple.
Comment 5 Carlos Garcia Campos 2017-11-27 02:57:43 PST
I think this was caused by the glib upgrade and fixed in glib, see https://git.gnome.org/browse/glib/commit/?id=281e301. I'm marking this as duplicate of #176806 because that bug has a bt, let's handle it there.

*** This bug has been marked as a duplicate of bug 176806 ***