Bug 171454 - WebAssembly: make sure tiering can run out of X memory gracefully
Summary: WebAssembly: make sure tiering can run out of X memory gracefully
Status: RESOLVED DUPLICATE of bug 171537
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 159775
  Show dependency treegraph
 
Reported: 2017-04-28 15:25 PDT by JF Bastien
Modified: 2017-06-23 23:01 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JF Bastien 2017-04-28 15:25:44 PDT
If We try to tier up a function but don't have X memory available for it then it should just stay at O1. Slow is better than dead. That's what we do for JS (stay in llint).
Comment 1 JF Bastien 2017-06-23 23:01:25 PDT

*** This bug has been marked as a duplicate of bug 171537 ***