Bug 17116 - Character clusters in complex scripts can not span colors or other formatting
: Character clusters in complex scripts can not span colors or other formatting
Status: RESOLVED DUPLICATE of bug 6148
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 08:40 PST by Brett Wilson (Google)
Modified: 2008-01-31 13:11 PST (History)
0 users

See Also:


Attachments
Example page (1.41 KB, text/html)
2008-01-31 08:41 PST, Brett Wilson (Google)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brett Wilson (Google) 2008-01-31 08:40:45 PST
There is a set of formatting changes such as text color that should not cause a break in runs when composing complex scripts. IE seems to do a good job here.

WebKit breaks the text runs on this color change and sends each one individually to the font system (ASTUI, etc.), so the context is lost and there is no shaping across the boundary. I suspect this drawing should happen more like selections, where it gives the entire run to the font system, but specifies a subset of the string to draw with specified style. This will allow the font system to do shaping and then just draw the subset of characters relating to the current style.
Comment 1 Brett Wilson (Google) 2008-01-31 08:41:07 PST
Created attachment 18816 [details]
Example page
Comment 2 Alexey Proskuryakov 2008-01-31 13:11:48 PST

*** This bug has been marked as a duplicate of 6148 ***