Bug 17107 - REGRESSION(r29834): Article text on redhat.com magazine site appears to be painting twice
Summary: REGRESSION(r29834): Article text on redhat.com magazine site appears to be pa...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: mitz
URL: http://www.redhat.com/magazine/009jul...
Keywords: HasReduction, InRadar, Regression
: 17117 17120 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-30 18:03 PST by Mark Rowe (bdash)
Modified: 2008-01-31 10:50 PST (History)
3 users (show)

See Also:


Attachments
Reduction (127 bytes, text/html)
2008-01-30 18:03 PST, Mark Rowe (bdash)
no flags Details
Avoid making blocks paint floats that intrude into them (42.27 KB, patch)
2008-01-30 19:15 PST, mitz
no flags Details | Formatted Diff | Diff
Avoid making blocks paint floats that intrude into them (46.17 KB, patch)
2008-01-30 22:24 PST, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rowe (bdash) 2008-01-30 18:03:01 PST
When comparing the text rendering on http://www.redhat.com/magazine/009jul05/features/execshield/ between Safari 3 and TOT, it is clear that TOTs rendering is much bolder.  It seems like the text may be being painted twice.

Bisecting the revision history with git revealed that the problem originates with <http://trac.webkit.org/projects/webkit/changeset/29834>.
Comment 1 Mark Rowe (bdash) 2008-01-30 18:03:45 PST
Created attachment 18806 [details]
Reduction
Comment 2 Mark Rowe (bdash) 2008-01-30 18:04:22 PST
<rdar://problem/5716722>
Comment 3 mitz 2008-01-30 19:15:03 PST
Created attachment 18807 [details]
Avoid making blocks paint floats that intrude into them
Comment 4 Sam Weinig 2008-01-30 19:41:56 PST
; in that case...???  You sir, have a case of sentence truncation!
Comment 5 mitz 2008-01-30 21:27:45 PST
Comment on attachment 18807 [details]
Avoid making blocks paint floats that intrude into them

Sam also pointed out that the isDescendantOf() can be expensive. I think I can avoid it in most cases.
Comment 6 mitz 2008-01-30 22:24:20 PST
Created attachment 18809 [details]
Avoid making blocks paint floats that intrude into them
Comment 7 mitz 2008-01-31 10:25:55 PST
*** Bug 17117 has been marked as a duplicate of this bug. ***
Comment 8 Dave Hyatt 2008-01-31 10:32:48 PST
Comment on attachment 18809 [details]
Avoid making blocks paint floats that intrude into them

r=me
Comment 9 mitz 2008-01-31 10:36:48 PST
Fixed in <http://trac.webkit.org/projects/webkit/changeset/29885>.
Comment 10 Mark Rowe (bdash) 2008-01-31 10:50:39 PST
*** Bug 17120 has been marked as a duplicate of this bug. ***