Bug 170987 - [GTK] WebKitAutocleanups.h regression in v2.16.1 release
Summary: [GTK] WebKitAutocleanups.h regression in v2.16.1 release
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk (show other bugs)
Version: Other
Hardware: All Unspecified
: P2 Normal
Assignee: Adrian Perez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-19 05:12 PDT by Adrian Perez
Modified: 2017-04-19 06:00 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.62 KB, patch)
2017-04-19 05:15 PDT, Adrian Perez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Perez 2017-04-19 05:12:47 PDT
As reported in this post by Robert Bisewski:

  https://lists.webkit.org/pipermail/webkit-gtk/2017-April/003012.html

Original e-mail text follows.

----

I was attempting to compile my webkit2-based browser `sighte` using the
new v2.16.1 release of webkit2-gtk when I noticed the following warning
from my gcc v6.3.0 compiler:

/usr/include/webkitgtk-4.0/webkit2/WebKitAutocleanups.h:83:77: 
warning: ISO C does not allow extra ‘;’ outside of a function
[-Wpedantic] G_DEFINE_AUTOPTR_CLEANUP_FUNC (WebKitWebsiteData, 
webkit_website_data_unref);

This is no means a hold up for my project, but the warning did not
appear before, so I figured taking a bit of time to track down exactly
what was causing it would be in order.

While I am not exactly well-versed at your code base, just glancing
quickly from Trac leads me to believe that the specific commit appears
to be this one:

https://trac.webkit.org/changeset/214163/webkit

Simply removing the aforementioned ; character from the file
WebKitAutocleanups.h on line 83 seems to resolve the warning in
question.

If adding the semi-colon is not intended, then I hope you find this
helpful :)
Comment 1 Adrian Perez 2017-04-19 05:15:08 PDT
Created attachment 307476 [details]
Patch
Comment 2 Build Bot 2017-04-19 05:18:00 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 WebKit Commit Bot 2017-04-19 06:00:40 PDT
Comment on attachment 307476 [details]
Patch

Clearing flags on attachment: 307476

Committed r215508: <http://trac.webkit.org/changeset/215508>
Comment 4 WebKit Commit Bot 2017-04-19 06:00:41 PDT
All reviewed patches have been landed.  Closing bug.