Bug 170688 - [WK2][macOS] Move away from AppKit runloop
Summary: [WK2][macOS] Move away from AppKit runloop
Status: RESOLVED DUPLICATE of bug 179804
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-04-10 12:45 PDT by Brent Fulgham
Modified: 2018-01-23 16:52 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2017-04-10 12:45:57 PDT
The various WebKit2 processes were created using the full AppKit runloop. Since AppKit is designed to support full applications, it has features that are not needed for our focused lower-level WebKit processes.

We should move to a lower-level runloop concept so that we can tighten the sandboxes on WebProcess, NetworkProcess, etc., even further.
Comment 1 Brent Fulgham 2017-04-10 12:46:22 PDT
<rdar://problem/14012823>
Comment 2 Jonathan Bedard 2018-01-23 16:52:31 PST
Forward-duping to <https://bugs.webkit.org/show_bug.cgi?id=179804>.

*** This bug has been marked as a duplicate of bug 179804 ***