Bug 17053 - misplaced text in SVG
: misplaced text in SVG
Status: RESOLVED DUPLICATE of bug 12448
Product: WebKit
Classification: Unclassified
Component: SVG
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Nobody
: NeedsReduction
Depends on:
  Show dependency treegraph
Reported: 2008-01-28 17:29 PST by Nicholas Shanks
Modified: 2011-02-01 04:02 PST (History)
3 users (show)

See Also:

Reduction to an ellipse with text (432 bytes, image/svg+xml)
2008-02-04 12:31 PST, Chasen Le Hara
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Shanks 2008-01-28 17:29:02 PST
The SVG file at http://gunther.ne.keryx.se/ie8-metatag.svg renders like this in Firefox on Linux (apparently): http://gunther.ne.keryx.se/ie8-metatag.png
I don't know what's wrong or as a consequence, if this is a duplicate bug. And it's the middle of the night and I'm too tired to check.
Comment 1 Chasen Le Hara 2008-02-04 12:31:53 PST
Created attachment 18915 [details]
Reduction to an ellipse with text

Confirmed in r29955.
Comment 2 Lars Gunther 2008-03-24 03:12:49 PDT
Although it does not look the same exactly as in Firefox, I think it is a similar issue, namely kerning. When Gecko recently landed a fix for kerning my SVG rendered perfectly.

I have just updated the status page: http://keryx.se/dev/svg/geckobug-08-01/ From there you may also see my original SVG file at http://keryx.se/dev/svg/geckobug-08-01/ie8-metatag.html The URL above will be removed shortly.
Comment 3 Nikolas Zimmermann 2011-02-01 04:02:35 PST
The patch on bug 12448 fixes this problem. Thanks a lot for the testcase, I've integrated it in my patch.

*** This bug has been marked as a duplicate of bug 12448 ***