Bug 170499 - [GTK+] PNG animations that should run once are not played at all
Summary: [GTK+] PNG animations that should run once are not played at all
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Miguel Gomez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-05 02:14 PDT by Miguel Gomez
Modified: 2017-04-05 03:09 PDT (History)
3 users (show)

See Also:


Attachments
Patch (2.63 KB, patch)
2017-04-05 02:19 PDT, Miguel Gomez
no flags Details | Formatted Diff | Diff
Patch (2.69 KB, patch)
2017-04-05 02:26 PDT, Miguel Gomez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Gomez 2017-04-05 02:14:22 PDT
The problem is the repetition count that is being returned from PNGImageDecoder.
Comment 1 Miguel Gomez 2017-04-05 02:19:20 PDT
Created attachment 306274 [details]
Patch
Comment 2 Miguel Gomez 2017-04-05 02:26:50 PDT
Created attachment 306275 [details]
Patch
Comment 3 WebKit Commit Bot 2017-04-05 03:09:14 PDT
Comment on attachment 306275 [details]
Patch

Clearing flags on attachment: 306275

Committed r214939: <http://trac.webkit.org/changeset/214939>
Comment 4 WebKit Commit Bot 2017-04-05 03:09:16 PDT
All reviewed patches have been landed.  Closing bug.