Bug 17048 - REGRESSION (r20997): createAttribute is supposed to create an Attr with localName of null (LayoutTests/dom/xhtml/level3/core/nodeisequalnode14.xhtml)
Summary: REGRESSION (r20997): createAttribute is supposed to create an Attr with local...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar, Regression
Depends on: 17060
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 13:17 PST by David Kilzer (:ddkilzer)
Modified: 2016-08-30 09:44 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2008-01-28 13:17:53 PST
* SUMMARY
Subversion revision r20997 <http://trac.webkit.org/projects/webkit/changeset/20997> caused LayoutTests/dom/xhtml/level3/core/nodeisequalnode14.xhtml to regress.  The explanation given in the LayoutTests/ChangeLog entry was:

* dom/xhtml/level3/core/nodeisequalnode14-expected.txt: This test fails because createAttribute is supposed to create an Attr with localName of null.

This bug was filed to track this regression and (potentially) fix createAttribute.

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Open LayoutTests/dom/xhtml/level3/core/nodeisequalnode14.xhtml in the browser.

* RESULTS
The test fails.

* REGRESSION
This is a regression from r20997.  In WebKit nightly builds before r20997, this test passed.  Note that the test did not work at all in shipping Safari 2, and was failing by the time Safari 3 was released.

* NOTES
See Bug 5262 for the original bug fix that caused the regression.
Comment 1 David Kilzer (:ddkilzer) 2008-01-28 13:19:13 PST
<rdar://problem/5710854>

Comment 2 Alexey Proskuryakov 2008-01-28 23:16:59 PST
FWIW, we match Firefox 3 beta on this test. Firefox 2 doesn't support isEqualNode, but document.createAttribute("root").localName is also equal to "root".
Comment 3 Eric Seidel (no email) 2008-02-03 04:45:54 PST
This failure is documented by the "fast/dom/Node/initial-values.html" test case soon to be landed as part of:
http://bugs.webkit.org/show_bug.cgi?id=17060
Comment 4 David Kilzer (:ddkilzer) 2008-02-23 13:30:04 PST
See also Bug 17167.

Comment 5 David Kilzer (:ddkilzer) 2016-08-30 09:44:42 PDT
Chris Dumez says in <rdar://problem/5710854>:
'''
This test is failing in all browsers. I think it is safe to assume it is outdated.

attr1 = doc.createAttribute("root");
// create an attribute whose localName is “root”. The namespaceURI is null by default.

attr2 = doc.createAttributeNS(nullNSURI,"root");
// create an attribute whose localName is “root” and namespaceURI is null.

The test expects  attr1.isEqualNode(attr2) to be false. However, the created attributes are identical so the test is indeed outdated.
'''