Bug 170457 - [GTK] Update the priorities used in glib main loop sources
Summary: [GTK] Update the priorities used in glib main loop sources
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on: 171218
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-04 10:26 PDT by Carlos Garcia Campos
Modified: 2017-04-24 07:01 PDT (History)
4 users (show)

See Also:


Attachments
Patch (16.31 KB, patch)
2017-04-04 10:44 PDT, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff
Patch (21.59 KB, patch)
2017-04-07 02:33 PDT, Carlos Garcia Campos
zan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2017-04-04 10:26:29 PDT
We use a different priority for the main thread shared timer to match GDK_PRIORITY_REDRAW, but that doesn't make much sense nowadays because there aren't GDK events in the web process anymore. But it still makes sense to use different priorities depending on the kind of source.
Comment 1 Carlos Garcia Campos 2017-04-04 10:44:11 PDT
Created attachment 306177 [details]
Patch
Comment 2 Carlos Garcia Campos 2017-04-07 02:33:17 PDT
Created attachment 306479 [details]
Patch
Comment 3 Carlos Garcia Campos 2017-04-07 03:43:57 PDT
Committed r215088: <http://trac.webkit.org/changeset/215088>
Comment 4 Michael Catanzaro 2017-04-24 07:01:24 PDT
Regression in bug #171218