Bug 170373 - REGRESSION(r213682): Web Inspector: Network columns don't get saved when Web Inspector is closed
Summary: REGRESSION(r213682): Web Inspector: Network columns don't get saved when Web ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Joseph Pecoraro
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-03-31 17:18 PDT by Nikita Vasilyev
Modified: 2017-04-17 21:55 PDT (History)
5 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (2.14 KB, patch)
2017-04-17 15:36 PDT, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Vasilyev 2017-03-31 17:18:43 PDT
Steps:
1. Open Network tab.
2. Right click on one of the column headers, such as Domain.
3. Uncheck Domain to hide it.
4. Close Web Inspector.
5. Open Web Inspector.

Expected:
Domain column stays hidden.

Actual:
Domain column is visible. No matter what changes in column visibility were made, they don't get saved.
Comment 1 Radar WebKit Bug Importer 2017-03-31 20:57:43 PDT
<rdar://problem/31386336>
Comment 2 Joseph Pecoraro 2017-04-17 15:33:44 PDT
I don't think this was ever working.
Comment 3 Joseph Pecoraro 2017-04-17 15:36:42 PDT
Created attachment 307307 [details]
[PATCH] Proposed Fix
Comment 4 Joseph Pecoraro 2017-04-17 15:39:32 PDT
NVI corrects me, this was working in the past.

In that case, this would have regressed with:
<https://trac.webkit.org/r213682>

Which made it possible to save the hidden/visible state of default hidden columns. It didn't work for default visible columns because `columnInfo.hidden` was undefined.
Comment 5 Nikita Vasilyev 2017-04-17 15:44:59 PDT
Comment on attachment 307307 [details]
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=307307&action=review

Looks good to me.

> Source/WebInspectorUI/ChangeLog:14
> +        we always get an explicit boolean.

This is indeed what was happening.
Comment 6 Matt Baker 2017-04-17 21:23:59 PDT
Comment on attachment 307307 [details]
[PATCH] Proposed Fix

r=me. I think eventually it would be nice to have a DataGridColumn object that sanitizes these types of settings.
Comment 7 WebKit Commit Bot 2017-04-17 21:55:43 PDT
Comment on attachment 307307 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 307307

Committed r215449: <http://trac.webkit.org/changeset/215449>
Comment 8 WebKit Commit Bot 2017-04-17 21:55:45 PDT
All reviewed patches have been landed.  Closing bug.