Bug 17026 - The letters "j" "y" and others leaves pixels on screen
Summary: The letters "j" "y" and others leaves pixels on screen
Status: RESOLVED DUPLICATE of bug 6274
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2008-01-26 16:34 PST by José Jeria
Modified: 2014-09-03 11:22 PDT (History)
5 users (show)

See Also:


Attachments
Testcase (1.16 KB, text/html)
2008-01-26 16:35 PST, José Jeria
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description José Jeria 2008-01-26 16:34:21 PST
See testcase. Dragging around the orange div containing the letter "j" will leave trails on the screen.
Comment 1 José Jeria 2008-01-26 16:35:07 PST
Created attachment 18712 [details]
Testcase

Drag and drop the orange box.
Comment 2 Mark Rowe (bdash) 2008-01-26 16:56:42 PST
Dan suggested this is probably due to the same root cause as bug 12607.
Comment 3 mitz 2008-01-26 22:15:00 PST
There is no easy and efficient way to tell whether and by how much text will overflow its "typographic bounds", but perhaps WebCore can do a better job at estimating it (e.g. for italics, add a horizontal overflow of sin(italics angle) * (ascent + descent) / 2 on either side).
Comment 4 David Kilzer (:ddkilzer) 2008-02-20 08:19:51 PST
<rdar://problem/5754452>
Comment 5 David Kilzer (:ddkilzer) 2014-09-03 11:22:14 PDT
Myles thinks this is a duplicate of Bug 6274.

*** This bug has been marked as a duplicate of bug 6274 ***