Bug 170206 - webkitpy: Add IOSDevicePort and IOSPort tests
Summary: webkitpy: Add IOSDevicePort and IOSPort tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jonathan Bedard
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-03-28 15:01 PDT by Jonathan Bedard
Modified: 2017-03-29 10:22 PDT (History)
6 users (show)

See Also:


Attachments
Patch (18.21 KB, patch)
2017-03-28 15:03 PDT, Jonathan Bedard
no flags Details | Formatted Diff | Diff
Patch (20.04 KB, patch)
2017-03-29 08:30 PDT, Jonathan Bedard
no flags Details | Formatted Diff | Diff
Patch for landing (20.07 KB, patch)
2017-03-29 10:05 PDT, Jonathan Bedard
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Bedard 2017-03-28 15:01:06 PDT
We only have unit tests for IOSSimulatorPort.  Add unit tests for IOSDevicePort and IOSPort.
Comment 1 Radar WebKit Bug Importer 2017-03-28 15:02:31 PDT
<rdar://problem/31308364>
Comment 2 Jonathan Bedard 2017-03-28 15:03:10 PDT
Created attachment 305647 [details]
Patch
Comment 3 Alexey Proskuryakov 2017-03-28 16:27:41 PDT
Comment on attachment 305647 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=305647&action=review

r=me, please fix class naming.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:27
> +class iosDeviceTest(ios_testcase.iOSTest):

Although there is one test class named like this, the WebKit style calls for "IOSDeviceTest" as the name. Most iOS classes in webkitpy follow the style.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:28
> +    os_name = 'ios-device'

This shows a shortcoming in the code - the OS name is iOS, not iOS Device.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:31
> +    port_maker = IOSDevicePort

Maker is a strange name, there is no pattern like this that I'm aware of.

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:32
> +    is_simulator = True

Wut?

> Tools/Scripts/webkitpy/port/ios_device_unittest.py:36
> +        port.set_option('child_processes', 1)

This is worth explaining if it's needed (is it?)

> Tools/Scripts/webkitpy/port/ios_simulator_unittest.py:32
> +class iosSimulatorTest(ios_testcase.iOSTest):

Ditto w.r.t. naming.
Comment 4 Jonathan Bedard 2017-03-29 08:30:53 PDT
Created attachment 305735 [details]
Patch
Comment 5 Jonathan Bedard 2017-03-29 10:05:42 PDT
Created attachment 305752 [details]
Patch for landing
Comment 6 WebKit Commit Bot 2017-03-29 10:22:05 PDT
Comment on attachment 305752 [details]
Patch for landing

Clearing flags on attachment: 305752

Committed r214542: <http://trac.webkit.org/changeset/214542>
Comment 7 WebKit Commit Bot 2017-03-29 10:22:08 PDT
All reviewed patches have been landed.  Closing bug.