Bug 170179 - VoiceOver does not announce a list for groups of links when list-style: none;
Summary: VoiceOver does not announce a list for groups of links when list-style: none;
Status: RESOLVED DUPLICATE of bug 134187
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: Safari 10
Hardware: All iOS 10
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-28 09:08 PDT by Izabella Cornwell
Modified: 2018-05-16 02:51 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Izabella Cornwell 2017-03-28 09:08:23 PDT
VoiceOver on Safari 9.1.3 (MacPro) and 10.2.1 (iPAD/iPhone) does not announce a list for a groups of links when list-style is set to none

}
ul.navigation {
  list-style: none; 
  padding: 0;
}
<ul class="navigation">
    <li><a href="kitchen.html">Kitchen</a></li>
    <li><a href="bedbath.html">Bed &amp; Bath</a></li>
    <li><a href="dining.html">Fine Dining</a></li>
    <li><a href="lighting.html">Lighting</a></li>
    <li><a href="storage.html">Storage</a><li>
</ul> 

url to test/verify: navigation tab menu at: https://www.w3.org/WAI/demos/bad/after/home.html
Comment 1 James Craig 2018-05-16 02:51:09 PDT
This was a purposeful change due to rampant "list"-itis by web developers. 

In the same way WebKit differentiates layout tables from data tables, it now differentiates layout lists from data lists. VoiceOver users always used to file bugs that there were too many "start of list" "end of list" announcements on the Web. Customers seems much happier in the 3 years since this change went in.

Basically, if you remove all default visible indication of the list, there is no indication to a sighted user or screen reader user that the content is a list. If you want to override this heuristic for accessibility, you can always add an explicit ARIA role="list".

Read more about in bug 134187 or view the test case attachment 
https://bugs.webkit.org/attachment.cgi?id=233587

*** This bug has been marked as a duplicate of bug 134187 ***