Bug 17004 - Assertion failure in VisiblePosition::previous clicking on 92/100 text on Acid3 results
Summary: Assertion failure in VisiblePosition::previous clicking on 92/100 text on Aci...
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://acid3.acidtests.org/
Keywords: InRadar
: 17059 17867 (view as bug list)
Depends on:
Blocks: Acid3
  Show dependency treegraph
 
Reported: 2008-01-25 02:28 PST by Alexey Proskuryakov
Modified: 2008-03-19 15:36 PDT (History)
3 users (show)

See Also:


Attachments
reduced test case (112 bytes, text/html)
2008-03-12 06:47 PDT, Alexey Proskuryakov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2008-01-25 02:28:36 PST
Steps to reproduce:
1. Open http://hixie.ch/tests/evil/acid/003/NOT_READY_PLEASE_DO_NOT_USE.html
2. As it finishes, click on the result numbers (e.g. 67/100).

An assertion fails:
(/Users/ap/Safari/OpenSource/WebCore/editing/VisiblePosition.cpp:85 WebCore::VisiblePosition WebCore::VisiblePosition::previous(bool) const)

Thread 0 Crashed:
0   com.apple.WebCore             	0x01f9439d WebCore::VisiblePosition::previous(bool) const + 169 (VisiblePosition.cpp:85)
1   com.apple.WebCore             	0x02005e90 WebCore::positionAvoidingFirstPositionInTable(WebCore::VisiblePosition const&) + 38 (visible_units.cpp:271)
2   com.apple.WebCore             	0x02006088 WebCore::startPositionForLine(WebCore::VisiblePosition const&) + 426 (visible_units.cpp:321)
3   com.apple.WebCore             	0x020060aa WebCore::startOfLine(WebCore::VisiblePosition const&) + 18 (visible_units.cpp:328)
4   com.apple.WebCore             	0x02006304 WebCore::inSameLine(WebCore::VisiblePosition const&, WebCore::VisiblePosition const&) + 50 (visible_units.cpp:415)
5   com.apple.WebCore             	0x01f93de7 WebCore::VisiblePosition::init(WebCore::Position const&, WebCore::EAffinity) + 149 (VisiblePosition.cpp:61)
6   com.apple.WebCore             	0x01f93ea5 WebCore::VisiblePosition::VisiblePosition(WebCore::Node*, int, WebCore::EAffinity) + 133 (VisiblePosition.cpp:51)
7   com.apple.WebCore             	0x01f93edc WebCore::VisiblePosition::VisiblePosition(WebCore::Node*, int, WebCore::EAffinity) + 38 (VisiblePosition.cpp:52)
8   com.apple.WebCore             	0x01e58599 WebCore::RenderText::positionForCoordinates(int, int) + 885 (RenderText.cpp:296)
9   com.apple.WebCore             	0x01b8309f WebCore::RenderObject::positionForPoint(WebCore::IntPoint const&) + 77 (RenderObject.h:523)
10  com.apple.WebCore             	0x01b7dc2d WebCore::EventHandler::handleMousePressEventSingleClick(WebCore::MouseEventWithHitTestResults const&) + 443 (EventHandler.cpp:260)
11  com.apple.WebCore             	0x01b7e4b6 WebCore::EventHandler::handleMousePressEvent(WebCore::MouseEventWithHitTestResults const&) + 680 (EventHandler.cpp:344)
12  com.apple.WebCore             	0x01b82dd7 WebCore::EventHandler::handleMousePressEvent(WebCore::PlatformMouseEvent const&) + 1717 (EventHandler.cpp:905)
13  com.apple.WebCore             	0x01b870e8 WebCore::EventHandler::mouseDown(NSEvent*) + 554 (EventHandlerMac.mm:480)
14  com.apple.WebKit              	0x001d1b5d -[WebHTMLView mouseDown:] + 499 (WebHTMLView.mm:2979)
Comment 1 Eric Seidel (no email) 2008-01-29 00:20:37 PST
*** Bug 17059 has been marked as a duplicate of this bug. ***
Comment 2 Alexey Proskuryakov 2008-03-12 06:47:34 PDT
Created attachment 19698 [details]
reduced test case
Comment 3 Alexey Proskuryakov 2008-03-12 07:16:27 PDT
<rdar://problem/5794920>
Comment 4 Justin Garcia 2008-03-12 13:50:56 PDT
I'm looking at this.  upstream and downstream don't really understand inline-blocks, which confuses VisiblePosition::canonicalPosition...
Comment 5 Matt Lilek 2008-03-15 17:17:29 PDT
*** Bug 17867 has been marked as a duplicate of this bug. ***
Comment 6 Justin Garcia 2008-03-18 16:27:16 PDT
Getting close on this...
Comment 7 Eric Seidel (no email) 2008-03-19 15:36:33 PDT
This was: http://trac.webkit.org/projects/webkit/changeset/31161