Bug 169939 - REGRESSION(STP): rgb() with calc() containing variables doesn't work
Summary: REGRESSION(STP): rgb() with calc() containing variables doesn't work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: Safari Technology Preview
Hardware: Macintosh OS X 10.11
: P2 Normal
Assignee: Dave Hyatt
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-03-21 18:12 PDT by Greg Whitworth
Modified: 2017-05-04 08:41 PDT (History)
5 users (show)

See Also:


Attachments
Patch for EWS (851 bytes, patch)
2017-04-27 11:22 PDT, Dave Hyatt
no flags Details | Formatted Diff | Diff
Patch (3.22 KB, patch)
2017-05-04 07:53 PDT, Dave Hyatt
zalan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Whitworth 2017-03-21 18:12:20 PDT
This is currently working in stable Safari but seems to have regressed: https://jsbin.com/metobigecu/1/edit?css,output

Expected: Background is Green
Actual: Red

We discovered this while working on a demo for Microsoft Edge custom properties. FF fails due to no calc support in color functions and Chrome doesn't support float values in Calc(). Webkit seems to have the same issue for calc() but doesn't if you're using a variable. At any rate, would be great to see this fixed.
Comment 1 Radar WebKit Bug Importer 2017-03-23 09:37:25 PDT
<rdar://problem/31221151>
Comment 2 Dave Hyatt 2017-04-03 15:35:40 PDT
We brought consistency to this, so we fail whether you use a variable or not.
Comment 3 Dave Hyatt 2017-04-27 11:22:56 PDT
Created attachment 308413 [details]
Patch for EWS
Comment 4 Dave Hyatt 2017-05-04 07:53:05 PDT
Created attachment 309046 [details]
Patch
Comment 5 Dave Hyatt 2017-05-04 08:41:25 PDT
Landed in r216188.