Bug 169783 - Clients of JSArray::tryCreateForInitializationPrivate() should do their own null checks.
Summary: Clients of JSArray::tryCreateForInitializationPrivate() should do their own n...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords: InRadar
: 170804 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-16 14:28 PDT by Mark Lam
Modified: 2017-05-02 11:48 PDT (History)
7 users (show)

See Also:


Attachments
proposed patch. (11.93 KB, patch)
2017-03-23 12:06 PDT, Mark Lam
sbarati: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2017-03-16 14:28:39 PDT
Patch coming.
Comment 1 Radar WebKit Bug Importer 2017-03-16 14:29:37 PDT
<rdar://problem/31098926>
Comment 2 Mark Lam 2017-03-23 12:06:31 PDT
Created attachment 305209 [details]
proposed patch.
Comment 3 Saam Barati 2017-03-23 12:33:04 PDT
Comment on attachment 305209 [details]
proposed patch.

r=me
Comment 4 Mark Lam 2017-03-23 13:35:04 PDT
Thanks for the review.  Landed in r214313: <https://trac.webkit.org/changeset/214313>.
Comment 5 Mark Lam 2017-05-02 11:48:33 PDT
*** Bug 170804 has been marked as a duplicate of this bug. ***