Bug 169706 - Shadow element styles based on host attributes do not update
Summary: Shadow element styles based on host attributes do not update
Status: RESOLVED DUPLICATE of bug 170762
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: Safari Technology Preview
Hardware: Macintosh macOS 10.12
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-03-15 15:37 PDT by Jan Miksovsky
Modified: 2017-05-08 18:35 PDT (History)
5 users (show)

See Also:


Attachments
Repro case (1.32 KB, text/html)
2017-05-08 17:35 PDT, Jan Miksovsky
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Miksovsky 2017-03-15 15:37:51 PDT
See http://jsbin.com/gubocem/edit?html,output

Expect: Clicking the indicated element updates its `toggle` attribute, which should in turn apply a style rule changing the background color. This works as expected in Chrome.

Actual: Clicking the element updates the attribute, but not the style. Using the inspector to manually disable the rule for `background` and re-enable it causes the rule to be applied as expected.

We've encountered various flavors of this bug before: https://bugs.webkit.org/show_bug.cgi?id=112869 and https://bugs.webkit.org/show_bug.cgi?id=158900.
Comment 1 Radar WebKit Bug Importer 2017-03-15 19:23:46 PDT
<rdar://problem/31080691>
Comment 2 Jan Miksovsky 2017-05-08 17:35:10 PDT
Created attachment 309447 [details]
Repro case

Adding the repro case as an attachment, as jsbin.com seems to be down/flaky.
Comment 3 Ryosuke Niwa 2017-05-08 18:35:24 PDT

*** This bug has been marked as a duplicate of bug 170762 ***