Bug 169472 - Move libwebrtc backend to using tracks
Summary: Move libwebrtc backend to using tracks
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords:
Depends on:
Blocks: 169491
  Show dependency treegraph
 
Reported: 2017-03-10 09:16 PST by youenn fablet
Modified: 2017-03-10 16:46 PST (History)
4 users (show)

See Also:


Attachments
Patch (34.13 KB, patch)
2017-03-10 09:26 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (34.08 KB, patch)
2017-03-10 10:09 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch for landing (34.10 KB, patch)
2017-03-10 13:56 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (20.24 KB, patch)
2017-03-10 16:18 PST, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2017-03-10 09:16:13 PST
We should move to the newer libwebrtc API
Comment 1 youenn fablet 2017-03-10 09:26:47 PST
Created attachment 304047 [details]
Patch
Comment 2 WebKit Commit Bot 2017-03-10 09:27:37 PST
Attachment 304047 [details] did not pass style-queue:


ERROR: Source/WebCore/testing/MockLibWebRTCPeerConnection.h:209:  Should be indented on a separate line, with the colon or comma first on that line.  [whitespace/indent] [4]
ERROR: Source/WebCore/testing/MockLibWebRTCPeerConnection.h:215:  media_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/testing/MockLibWebRTCPeerConnection.h:217:  stream_ids is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 3 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 youenn fablet 2017-03-10 10:09:27 PST
Created attachment 304052 [details]
Patch
Comment 4 WebKit Commit Bot 2017-03-10 10:11:17 PST
Attachment 304052 [details] did not pass style-queue:


ERROR: Source/WebCore/testing/MockLibWebRTCPeerConnection.h:209:  Should be indented on a separate line, with the colon or comma first on that line.  [whitespace/indent] [4]
ERROR: Source/WebCore/testing/MockLibWebRTCPeerConnection.h:215:  media_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/testing/MockLibWebRTCPeerConnection.h:217:  stream_ids is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 3 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Alex Christensen 2017-03-10 10:49:18 PST
Comment on attachment 304052 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=304052&action=review

> Source/WebCore/Modules/mediastream/libwebrtc/LibWebRTCMediaEndpoint.cpp:177
> +    if (source.type() == RealtimeMediaSource::Audio) {

I think Type should be made an enum class instead of an enum and this should be made a switch statement.  Right now we are assuming that if a media source is not audio it is video, when there are three values in RealtimeMediaSource::Type.  That might be a good assumption, but I think switching on enums is good practice.
Comment 6 youenn fablet 2017-03-10 13:56:46 PST
Created attachment 304071 [details]
Patch for landing
Comment 7 youenn fablet 2017-03-10 16:18:51 PST
Created attachment 304092 [details]
Patch
Comment 8 WebKit Commit Bot 2017-03-10 16:46:48 PST
Comment on attachment 304071 [details]
Patch for landing

Clearing flags on attachment: 304071

Committed r213736: <http://trac.webkit.org/changeset/213736>
Comment 9 WebKit Commit Bot 2017-03-10 16:46:53 PST
All reviewed patches have been landed.  Closing bug.