Bug 169272 - [GTK] [WebCrypto] Add support for ECDH ImportKey/ExportKey operations
Summary: [GTK] [WebCrypto] Add support for ECDH ImportKey/ExportKey operations
Status: RESOLVED DUPLICATE of bug 172927
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Zan Dobersek
URL:
Keywords:
: 169469 169527 (view as bug list)
Depends on:
Blocks: 133122
  Show dependency treegraph
 
Reported: 2017-03-07 04:35 PST by Carlos Alberto Lopez Perez
Modified: 2017-07-03 01:53 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2017-03-07 04:35:22 PST
The following tests addded on bug 165723 fail on platform GTK+


imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/failures_ECDH.worker.html [ Failure ]
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/successes_ECDH.worker.html [ Failure ]
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/test_failures_ECDH.html [ Failure ]
imported/w3c/web-platform-tests/WebCryptoAPI/generateKey/test_successes_ECDH.html [ Failure ]


Looking at the diff, it seems we may lack an implementation for ECDH ?
Comment 1 Carlos Alberto Lopez Perez 2017-03-07 04:47:18 PST
TestExpectation file update at r213510: <http://trac.webkit.org/changeset/213510>
Comment 2 Javier Fernandez 2017-03-12 14:42:35 PDT
Mac Port implemented ECDH ImportKey/ExportKey operations already, so we may add the bits to support it in our WebKitGTK port.

https://www.w3.org/TR/WebCryptoAPI/#ecdh-operations.
Comment 3 Javier Fernandez 2017-03-12 14:43:04 PDT
*** Bug 169527 has been marked as a duplicate of this bug. ***
Comment 4 Javier Fernandez 2017-03-12 14:45:39 PDT
*** Bug 169469 has been marked as a duplicate of this bug. ***
Comment 5 Michael Catanzaro 2017-04-01 18:07:34 PDT
Zan, what are your plans for this?
Comment 6 Zan Dobersek 2017-04-02 23:33:30 PDT
(In reply to Michael Catanzaro from comment #5)
> Zan, what are your plans for this?

libgcrypt-based implementation is currently stashed in the patch in bug #133122.
Comment 7 Zan Dobersek 2017-07-03 01:53:08 PDT
This functionality is spread between patches in bugs #172927, #173646, #173647 and #173648. Marking this bug as a duplicate of the first one.

*** This bug has been marked as a duplicate of bug 172927 ***