Bug 169038 - REGRESSION: Image is missing on vorke.com
Summary: REGRESSION: Image is missing on vorke.com
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh Other
: P2 Normal
Assignee: Nobody
URL: http://vorke.com/products/vorke-z3
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-03-01 09:09 PST by Jens Bauer
Modified: 2017-03-01 10:04 PST (History)
6 users (show)

See Also:


Attachments
Webarchive of vorke.com/products/vorke-z3 plus two screenshots (1.86 MB, application/zip)
2017-03-01 09:09 PST, Jens Bauer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Bauer 2017-03-01 09:09:38 PST
Created attachment 303069 [details]
Webarchive of vorke.com/products/vorke-z3 plus two screenshots

I downloaded Leopard-webkit from this link:
https://sourceforge.net/projects/leopard-webkit/?source=typ_redirect
Version is r210430
I tried it out and it seemed it worked, so I re-linked my Safari 5.0.6 (PPC) to it.
I got a tremendous performance boost plus I can now access all the HTTPS sites I previously could not access, but it was like some content was missing.
Today (20170301) I found proof and I compared the original Safari with the relinked Safari.

On this website...
http://vorke.com/products/vorke-z3
... there is a box under "Specification"; this is supposed to contain an image which looks like a table, but the image is not being displayed.

At first I thought this was a Layout and Rendering bug, but it might be something else, because the missing content is an image, not text.

If I load the attached webarchive into the original Safari 5.0.6, it looks like expected.
If I load the attached webarchive into the relinked Safari 5.0.6, the image is missing.
(This webarchive is saved using the original Safari 5.0.6, but even if I saved from the relinked Safari it still shows alright in the original Safari).


Hardware: PowerMac G5, 2.5 GHz Quad-core with 2 x 2TB HDD in RAID0 configuration and 10 GB RAM.
System: Mac OS X 10.5.8
Safari version: 5.0.6
Relinked Safari: 5.0.6 relinked with r210430

Note: I cannot run any later operating system than Mac OS X 10.5.8 and I cannot run any later version of Safari than 5.0.6.
Comment 1 Alexey Proskuryakov 2017-03-01 10:04:16 PST
This is of course not a supported configuration, but I can reproduce with trunk on macOS 10.12. Works in Chrome.

Looks like some bad interaction between opacity and opacity transition.
Comment 2 Alexey Proskuryakov 2017-03-01 10:04:44 PST
Can't use Web Inspector to inspect CSS, filed bug 169041.
Comment 3 Radar WebKit Bug Importer 2017-03-01 10:04:50 PST
<rdar://problem/30784775>