Bug 168626 - Add machine-readable results for bindings tests
Summary: Add machine-readable results for bindings tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 138235 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-20 17:38 PST by Srinivasan Vijayaraghavan
Modified: 2017-03-03 12:50 PST (History)
7 users (show)

See Also:


Attachments
Patch (4.99 KB, patch)
2017-02-20 17:39 PST, Srinivasan Vijayaraghavan
no flags Details | Formatted Diff | Diff
Patch (4.61 KB, patch)
2017-02-23 14:43 PST, Srinivasan Vijayaraghavan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Srinivasan Vijayaraghavan 2017-02-20 17:38:42 PST
Adding JSON results to bindings tests is a prerequisite to running bindings tests on EWS.
Comment 1 Srinivasan Vijayaraghavan 2017-02-20 17:39:33 PST
Created attachment 302213 [details]
Patch
Comment 2 Srinivasan Vijayaraghavan 2017-02-20 17:42:15 PST
Note: webkit-patch upload failed trying to obsolete the attachment on the original bug, so I created a new bug and added the original to the 'See also' field.
Comment 3 Alexey Proskuryakov 2017-02-20 22:35:33 PST
*** Bug 138235 has been marked as a duplicate of this bug. ***
Comment 4 Alexey Proskuryakov 2017-02-20 22:39:07 PST
Comment on attachment 302213 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=302213&action=review

Looks reasonable to me, but I'd like Python experts to take a look too.

> Tools/Scripts/webkitpy/bindings/main.py:209
> +                'passes': self.passes,

Why is it desirable to add passes to the results too? I don't think that we do it elsewhere.
Comment 5 Aakash Jain 2017-02-21 09:59:29 PST
looks good to me, apart from Alexey comment.
Comment 6 Srinivasan Vijayaraghavan 2017-02-23 14:31:27 PST
(In reply to comment #4)
> Comment on attachment 302213 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=302213&action=review
> 
> Looks reasonable to me, but I'd like Python experts to take a look too.
> 
> > Tools/Scripts/webkitpy/bindings/main.py:209
> > +                'passes': self.passes,
> 
> Why is it desirable to add passes to the results too? I don't think that we
> do it elsewhere.

There's no need for it; I'll upload a new patch.
Comment 7 Srinivasan Vijayaraghavan 2017-02-23 14:43:01 PST
Created attachment 302581 [details]
Patch
Comment 8 Dean Johnson 2017-02-23 17:27:25 PST
Comment on attachment 302581 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=302581&action=review

Looks good overall. Food for thought below.

> Tools/Scripts/webkitpy/bindings/main.py:47
> +        if self.json_file_name:

All of the 'if self.json_file_name' might be a bit pre-mature for optimization. I don't think we will really see a performance hit from always appending errors/failure. The only one conditional I feel should remain is the one that actually does the writing to a file.

> Tools/Scripts/webkitpy/bindings/main.py:118
> +                if self.json_file_name:

Ditto.

> Tools/Scripts/webkitpy/bindings/main.py:125
> +                if self.json_file_name:

Ditto.
Comment 9 Alexey Proskuryakov 2017-02-24 14:18:28 PST
Comment on attachment 302581 [details]
Patch

I don't have a string opinion on the premature optimization. I agree that this is not necessary for performance, but the code may be easier to read when unnecessary work is not being done.
Comment 10 WebKit Commit Bot 2017-02-27 15:09:18 PST
Comment on attachment 302581 [details]
Patch

Clearing flags on attachment: 302581

Committed r213097: <http://trac.webkit.org/changeset/213097>
Comment 11 WebKit Commit Bot 2017-02-27 15:09:23 PST
All reviewed patches have been landed.  Closing bug.