Bug 168385 - Web Inspector: Split console should be allowed when docked bottom on Elements/Resources/Debugger/Storage tabs
Summary: Web Inspector: Split console should be allowed when docked bottom on Elements...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-15 12:31 PST by Devin Rousso
Modified: 2017-02-15 14:50 PST (History)
2 users (show)

See Also:


Attachments
Patch (5.09 KB, patch)
2017-02-15 14:22 PST, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2017-02-15 12:31:15 PST
Issue caused by r210911 <https://webkit.org/b/167075>.
Comment 1 Devin Rousso 2017-02-15 14:22:12 PST
Created attachment 301655 [details]
Patch
Comment 2 Matt Baker 2017-02-15 14:26:54 PST
Comment on attachment 301655 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=301655&action=review

> Source/WebInspectorUI/UserInterface/Views/DebuggerTabContentView.js:52
> +    get supportsSplitContentBrowser()

This override and the three that follow could be eliminated by changing ContentView.prototype.supportsSplitContentBrowser back to `return true`. This should work because of your change above.
Comment 3 Devin Rousso 2017-02-15 14:34:39 PST
Comment on attachment 301655 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=301655&action=review

>> Source/WebInspectorUI/UserInterface/Views/DebuggerTabContentView.js:52
>> +    get supportsSplitContentBrowser()
> 
> This override and the three that follow could be eliminated by changing ContentView.prototype.supportsSplitContentBrowser back to `return true`. This should work because of your change above.

I figured that it would be safer to make the default functionality be no split console when docked bottom and use a whitelist style of enabling tabs that we know work.  Then again we don't have many tabs so this doesn't matter too much.  If you would prefer it to be switched then I can change it  :D
Comment 4 WebKit Commit Bot 2017-02-15 14:50:18 PST
Comment on attachment 301655 [details]
Patch

Clearing flags on attachment: 301655

Committed r212400: <http://trac.webkit.org/changeset/212400>
Comment 5 WebKit Commit Bot 2017-02-15 14:50:27 PST
All reviewed patches have been landed.  Closing bug.