WebIOSEvent interface in WebCore/platform/ios/WebEvent.h is just a wrapper on top of WebEvent. This interface doesn't declare anything new and doesn't even have an implementation. We should use WebEvent directly.
Created attachment 301618 [details] Proposed patch
Attachment 301618 [details] did not pass style-queue: ERROR: Source/WebKit2/Shared/ios/WebIOSEventFactory.h:36: The parameter name "event" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 1 in 9 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 301618 [details] Proposed patch What's with all the ::? I thought ObjC classes don't have namespaces. Is there something else named WebEvent?
The immediate problem with WebIOSEvent is that it has no implementation, and thus breaks InstallAPI. That could be addressed by adding an implementation. But both Aakash and I think that subclassing shouldn't be used just to disambiguate names. Thoughts?
And yes, this is to disambiguate with WebEvent class in WebKit2. The modified files are all Objective-C++.
Comment on attachment 301618 [details] Proposed patch Clearing flags on attachment: 301618 Committed r212376: <http://trac.webkit.org/changeset/212376>
All reviewed patches have been landed. Closing bug.