RESOLVED FIXED 168097
[Cocoa] Add shouldChangeSelectedRange to WKWebProcessPlugInEditingDelegate
https://bugs.webkit.org/show_bug.cgi?id=168097
Summary [Cocoa] Add shouldChangeSelectedRange to WKWebProcessPlugInEditingDelegate
mitz
Reported 2017-02-09 17:38:34 PST
Expose InjectedBundle::EditorClient::shouldChangeSelectedRange via WKWebProcessPlugInEditingDelegate.
Attachments
Add new delegate method and make sure it is called for user-initiated changes on iOS as well (16.85 KB, patch)
2017-02-10 14:06 PST, mitz
thorton: review+
mitz
Comment 1 2017-02-10 14:06:04 PST
Created attachment 301198 [details] Add new delegate method and make sure it is called for user-initiated changes on iOS as well
WebKit Commit Bot
Comment 2 2017-02-10 14:07:53 PST
Attachment 301198 [details] did not pass style-queue: ERROR: Source/WebKit2/WebProcess/InjectedBundle/API/mac/WKWebProcessPlugInBrowserContextController.mm:610: This { should be at the end of the previous line [whitespace/braces] [4] Total errors found: 1 in 7 files If any of these errors are false positives, please file a bug against check-webkit-style.
Tim Horton
Comment 3 2017-02-10 14:08:35 PST
Comment on attachment 301198 [details] Add new delegate method and make sure it is called for user-initiated changes on iOS as well View in context: https://bugs.webkit.org/attachment.cgi?id=301198&action=review > Source/WebKit2/WebProcess/InjectedBundle/API/mac/WKWebProcessPlugInBrowserContextController.mm:621 > + toRange:toRange ? adoptNS([[WKDOMRange alloc] _initWithImpl:toRange]).get() : nil affinity:cocoaAffinity stillSelecting:stillSelecting]; Can we pull the range out into a variable so as not to have this insane syntax?
mitz
Comment 4 2017-02-10 14:18:14 PST
(In reply to comment #3) > Comment on attachment 301198 [details] > Add new delegate method and make sure it is called for user-initiated > changes on iOS as well > > View in context: > https://bugs.webkit.org/attachment.cgi?id=301198&action=review > > > Source/WebKit2/WebProcess/InjectedBundle/API/mac/WKWebProcessPlugInBrowserContextController.mm:621 > > + toRange:toRange ? adoptNS([[WKDOMRange alloc] _initWithImpl:toRange]).get() : nil affinity:cocoaAffinity stillSelecting:stillSelecting]; > > Can we pull the range out into a variable so as not to have this insane > syntax? OK. Committed <https://trac.webkit.org/r212149>.
Note You need to log in before you can comment on or make changes to this bug.