Bug 16799 - Acid3 expects HTMLObjectElement.data to canonicalize urls
: Acid3 expects HTMLObjectElement.data to canonicalize urls
Status: RESOLVED FIXED
: WebKit
HTML DOM
: 528+ (Nightly build)
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To:
: http://www.hixie.ch/tests/evil/acid/003/
: HasReduction
:
: 17064
  Show dependency treegraph
 
Reported: 2008-01-09 00:21 PST by
Modified: 2008-02-06 11:29 PST (History)


Attachments
Minimal test case (481 bytes, text/html)
2008-01-28 03:58 PST, Robert Blaut
no flags Details
Make data absolute (542 bytes, patch)
2008-02-04 15:22 PST, Dave Hyatt
mrowe: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-09 00:21:18 PST
Test 64: FAIL (expected ./test.html, got: test.html - object elements didn't resolve URIs correctly)

    function () {
      // test 64: attributes of the <object> element
      var obj1 = document.createElement('object');
      obj1.setAttribute('data', 'test.html');
      var obj2 = document.createElement('object');
      obj2.setAttribute('data', './test.html');
      assertEquals(obj1.data, obj2.data, "object elements didn't resolve URIs correctly");
      assert(obj1.data.match(/^http:/), "object.data isn't absolute");
      obj1.appendChild(document.createElement('param'));
      assertEquals(obj1.getElementsByTagName('param').length, 1, "object is missing its only child");
      return 4;
    },
------- Comment #1 From 2008-01-28 03:58:20 PST -------
Created an attachment (id=18735) [details]
Minimal test case
------- Comment #2 From 2008-02-04 15:22:02 PST -------
Created an attachment (id=18921) [details]
Make data absolute

Will land test case in bug.
------- Comment #3 From 2008-02-04 15:24:16 PST -------
(From update of attachment 18921 [details])
r=me
------- Comment #4 From 2008-02-04 15:25:56 PST -------
(From update of attachment 18921 [details])
+    if (dataVal.isNull())
+        return dataVal;

You don't need this. Document::completeURL already does this. It can just be a one-liner.

    return document()->completeURL(getAttribute(dataAttr));
------- Comment #5 From 2008-02-05 08:53:04 PST -------
*** Bug 14448 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2008-02-05 08:57:22 PST -------
you might want to review my patch in bug 14448, which includes a test case, but more importantly it had to be backed out after it was found to regress some existing layout tests!
------- Comment #7 From 2008-02-06 11:26:43 PST -------
I will just remove those layout tests, as they make a bogus assumption.
------- Comment #8 From 2008-02-06 11:29:57 PST -------
Fixed in r30044.