Bug 167946 - [GStreamer] ASSERTION FAILED: m_boundThread == currentThread() in _WebKitWebSrcPrivate::~_WebKitWebSrcPrivate
Summary: [GStreamer] ASSERTION FAILED: m_boundThread == currentThread() in _WebKitWebS...
Status: RESOLVED DUPLICATE of bug 152043
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-07 11:31 PST by Michael Catanzaro
Modified: 2017-02-11 11:58 PST (History)
2 users (show)

See Also:


Attachments
Full backtrace (599.79 KB, text/plain)
2017-02-07 11:31 PST, Michael Catanzaro
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2017-02-07 11:31:18 PST
Created attachment 300825 [details]
Full backtrace

This is probably a follow-up bug to bug #167003:

 * Load http://www.riverfronttimes.com/newsblog/2017/02/07/unions-seek-to-block-missouri-right-to-work-referendum-vote-likely-this-fall
 * Scroll down
 * Crash

Full backtrace attached. Truncated:

Thread 1 (Thread 0x7fb124c12ac0 (LWP 20285)):
#0  0x00007fb1164565ec in WTFCrash ()
    at ../../Source/WTF/wtf/Assertions.cpp:323
No locals.
#1  0x00007fb11ff37828 in WTF::WeakReference<WebCore::MainThreadNotifier<MainThreadSourceNotification> >::clear (this=0x7fb0aa3d4210)
    at ../../Source/WTF/wtf/WeakPtr.h:65
        __PRETTY_FUNCTION__ = "void WTF::WeakReference<T>::clear() [with T = WebCore::MainThreadNotifier<MainThreadSourceNotification>]"
#2  0x00007fb11ff369c8 in WTF::WeakPtrFactory<WebCore::MainThreadNotifier<MainThreadSourceNotification> >::~WeakPtrFactory (this=0xd0a00c8, 
    __in_chrg=<optimized out>) at ../../Source/WTF/wtf/WeakPtr.h:122
No locals.
#3  0x00007fb11ff3653a in (anonymous namespace)::MainThreadNotifier<MainThreadSourceNotification>::~MainThreadNotifier (this=0xd0a00c8, 
    __in_chrg=<optimized out>)
    at ../../Source/WebCore/platform/graphics/gstreamer/MainThreadNotifier.h:30
No locals.
#4  0x00007fb11ff365f2 in _WebKitWebSrcPrivate::~_WebKitWebSrcPrivate (
    this=0xd0a0040, __in_chrg=<optimized out>)
    at ../../Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:132
No locals.
#5  0x00007fb11ff2cc16 in webKitWebSrcFinalize (object=0xd0a0100)
    at ../../Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:331
        src = 0xd0a0100
        priv = 0xd0a0040

Looks like another thread-safety bug in the _WebKitWebSrcPrivate destructor. Note: bug #152043 looks related.
Comment 1 Michael Catanzaro 2017-02-11 11:58:42 PST

*** This bug has been marked as a duplicate of bug 152043 ***