Bug 167727 - [ESNext] Async iteration - Implement yield *: Delegation of async generator
Summary: [ESNext] Async iteration - Implement yield *: Delegation of async generator
Status: RESOLVED DUPLICATE of bug 175240
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 166693
  Show dependency treegraph
 
Reported: 2017-02-02 01:56 PST by GSkachkov
Modified: 2017-08-23 10:47 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GSkachkov 2017-02-02 01:56:04 PST
Implement yield* Delegation of async generator
https://tc39.github.io/proposal-async-iteration/#sec-asyncgenerator-definitions-evaluation
'''
function* boo() {
  yield 1;
  yield 2;
}

function* foo() {
  yield* boo();
  yield 3;
}

var iter = foo();

print(iter.next().value); // 1, done = false 
print(iter.next().value); // 2, done = false
print(iter.next().value); // 3, done = false
print(iter.next().value); // undefined, done = true
'''
Comment 1 GSkachkov 2017-08-23 10:47:50 PDT
Fixed in https://bugs.webkit.org/show_bug.cgi?id=175240

*** This bug has been marked as a duplicate of bug 175240 ***