Bug 167628 - [GTK] Horrible scrolling artifacts on http://prismjs.com/download.html
Summary: [GTK] Horrible scrolling artifacts on http://prismjs.com/download.html
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-30 21:34 PST by Michael Catanzaro
Modified: 2018-05-03 08:59 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2017-01-30 21:34:23 PST
Visit http://prismjs.com/download.html and scroll down. There are horrible graphical artifacts. Happens with or without AC mode.
Comment 1 Carlos Garcia Campos 2017-01-30 23:54:06 PST
I can't reproduce it.
Comment 2 Miguel Gomez 2017-01-31 00:39:54 PST
(In reply to comment #1)
> I can't reproduce it.

Neither can I. Must be already fixed.
Comment 3 Jérémy Lal 2017-01-31 00:52:31 PST
When resizing the window, weird things happen.
Comment 4 Carlos Garcia Campos 2017-01-31 01:00:54 PST
(In reply to comment #3)
> When resizing the window, weird things happen.

Yes, but that's not specific to that site, it happens when AC is enabled, it's probably due to new pixmap is uninitialized when resizing.
Comment 5 Michael Catanzaro 2017-01-31 09:45:31 PST
WTF. I can't reproduce it today either, but I have not changed my builds or configuration since yesterday. :(
Comment 6 Andres Gomez Garcia 2017-02-02 00:46:07 PST
With 2.15.4, I cannot reproduce right now with the reported URL.

However, I've seen some refreshing problems when scrolling other pages since this new release.
Comment 7 Adrian Perez 2018-05-03 04:36:18 PDT
I cannot reproduce this with WebKitGTK+ 2.20.1 anymore. Is this bug
report still relevant?
Comment 8 Michael Catanzaro 2018-05-03 08:59:17 PDT
Seems fixed.