Bug 167469 - Fix CPU / Memory diagnostic logging in PerformanceMonitor
Summary: Fix CPU / Memory diagnostic logging in PerformanceMonitor
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-01-26 15:14 PST by Chris Dumez
Modified: 2017-01-26 15:34 PST (History)
5 users (show)

See Also:


Attachments
Patch (10.01 KB, patch)
2017-01-26 15:18 PST, Chris Dumez
achristensen: review+
cdumez: commit-queue+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2017-01-26 15:14:42 PST
Fix CPU / Memory diagnostic logging in PerformanceMonitor to use logDiagnosticMessage() instead of logDiagnosticMessageWithValue(). logDiagnosticMessageWithValue() should only be used with numeric values.
Comment 1 Chris Dumez 2017-01-26 15:18:21 PST
Created attachment 299863 [details]
Patch
Comment 2 Chris Dumez 2017-01-26 15:20:30 PST
<rdar://problem/30220959>
Comment 3 Alex Christensen 2017-01-26 15:21:23 PST
Comment on attachment 299863 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=299863&action=review

> Source/WebCore/page/DiagnosticLoggingClient.h:42
> +    // FIXME: rename this to logDiagnosticMessageWithNumericValue().

Should its parameter be a String, then?
Comment 4 Chris Dumez 2017-01-26 15:24:11 PST
(In reply to comment #3)
> Comment on attachment 299863 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=299863&action=review
> 
> > Source/WebCore/page/DiagnosticLoggingClient.h:42
> > +    // FIXME: rename this to logDiagnosticMessageWithNumericValue().
> 
> Should its parameter be a String, then?

We end up passing a string to the underlying framework so this is not a big issue (although it may be clearer indeed). However, the string definitely needs to contain a numeric value.
Comment 5 Chris Dumez 2017-01-26 15:34:35 PST
Committed r211233: <http://trac.webkit.org/changeset/211233>