Bug 167301 - Remove allowWindowOpenWithoutUserGesture setting
Summary: Remove allowWindowOpenWithoutUserGesture setting
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Joseph Pecoraro
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-22 22:55 PST by Joseph Pecoraro
Modified: 2017-01-23 01:56 PST (History)
3 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (4.46 KB, patch)
2017-01-22 22:58 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff
[PATCH] Proposed Fix (4.34 KB, patch)
2017-01-22 23:16 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2017-01-22 22:55:24 PST
This Setting, used only by Mac WebKit1 is a duplicate of the javaScriptCanOpenWindowsAutomatically setting.

Comments on bug 159049 hinted at this, and it remains the case.
Comment 1 Joseph Pecoraro 2017-01-22 22:58:06 PST
Created attachment 299503 [details]
[PATCH] Proposed Fix
Comment 2 Joseph Pecoraro 2017-01-22 23:11:06 PST
Comment on attachment 299503 [details]
[PATCH] Proposed Fix

My build doesn't like this. Must have missed something...
Comment 3 Joseph Pecoraro 2017-01-22 23:16:59 PST
Created attachment 299504 [details]
[PATCH] Proposed Fix
Comment 4 WebKit Commit Bot 2017-01-23 00:00:16 PST
The commit-queue encountered the following flaky tests while processing attachment 299504 [details]:

editing/spelling/spellcheck-async-remove-frame.html bug 158401 (authors: morrita@google.com, rniwa@webkit.org, and tony@chromium.org)
The commit-queue is continuing to process your patch.
Comment 5 WebKit Commit Bot 2017-01-23 01:56:14 PST
Comment on attachment 299504 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 299504

Committed r211036: <http://trac.webkit.org/changeset/211036>
Comment 6 WebKit Commit Bot 2017-01-23 01:56:18 PST
All reviewed patches have been landed.  Closing bug.