Bug 167134 - Pointer lock events should be delivered directly to the target element
Summary: Pointer lock events should be delivered directly to the target element
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jeremy Jones
URL:
Keywords: InRadar
: 167133 167511 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-17 13:08 PST by Jeremy Jones
Modified: 2017-02-06 10:53 PST (History)
8 users (show)

See Also:


Attachments
Patch (8.28 KB, patch)
2017-01-17 13:16 PST, Jeremy Jones
no flags Details | Formatted Diff | Diff
Patch (12.16 KB, patch)
2017-01-25 19:09 PST, Jeremy Jones
no flags Details | Formatted Diff | Diff
Patch (12.78 KB, patch)
2017-02-02 16:15 PST, Jeremy Jones
no flags Details | Formatted Diff | Diff
Patch (12.84 KB, patch)
2017-02-02 16:19 PST, Jeremy Jones
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Jones 2017-01-17 13:08:03 PST
Pointer lock events should be delivered directly to the target element
Comment 1 Jeremy Jones 2017-01-17 13:08:39 PST
rdar://problem/30058933
Comment 2 Jeremy Jones 2017-01-17 13:16:36 PST
Created attachment 299055 [details]
Patch
Comment 3 Jon Lee 2017-01-25 17:36:55 PST
Comment on attachment 299055 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=299055&action=review

> LayoutTests/pointer-lock/mouse-event-delivery.html:50
> +                window.eventSender.mouseMoveTo(20,20);

why does this need to be added?
Comment 4 Jeremy Jones 2017-01-25 19:09:38 PST
Created attachment 299785 [details]
Patch
Comment 5 Jeremy Jones 2017-01-25 23:30:45 PST
(In reply to comment #3)
> Comment on attachment 299055 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=299055&action=review
> 
> > LayoutTests/pointer-lock/mouse-event-delivery.html:50
> > +                window.eventSender.mouseMoveTo(20,20);
> 
> why does this need to be added?

        The pointer-lock/mouse-event-delivery.html test is modified to explicitly move the mouse pointer to a valid
        location before sending mouse actions. Without this, the test infrastructure doesn't know that the pointer
        is over the web view and doesn't deliver events.
Comment 6 Jeremy Jones 2017-01-26 11:13:30 PST
*** Bug 167133 has been marked as a duplicate of this bug. ***
Comment 7 WebKit Commit Bot 2017-01-26 15:49:13 PST
Comment on attachment 299785 [details]
Patch

Clearing flags on attachment: 299785

Committed r211235: <http://trac.webkit.org/changeset/211235>
Comment 8 WebKit Commit Bot 2017-01-26 15:49:18 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Ryan Haddad 2017-01-30 10:20:35 PST
*** Bug 167511 has been marked as a duplicate of this bug. ***
Comment 10 Ryan Haddad 2017-01-30 10:21:10 PST
Rolled out the change in http://trac.webkit.org/projects/webkit/changeset/211375 due to frequent LayoutTest failures.
Comment 11 Jeremy Jones 2017-02-02 16:15:54 PST
Created attachment 300467 [details]
Patch
Comment 12 Jeremy Jones 2017-02-02 16:17:27 PST
rdar://problem/30268004
Comment 13 Jeremy Jones 2017-02-02 16:19:20 PST
Created attachment 300470 [details]
Patch
Comment 14 Dean Jackson 2017-02-03 11:58:51 PST
Comment on attachment 300470 [details]
Patch

I assume this is adding the same things that we do for touchmove and related events?
Comment 15 WebKit Commit Bot 2017-02-03 13:58:10 PST
Comment on attachment 300470 [details]
Patch

Clearing flags on attachment: 300470

Committed r211650: <http://trac.webkit.org/changeset/211650>
Comment 16 WebKit Commit Bot 2017-02-03 13:58:15 PST
All reviewed patches have been landed.  Closing bug.