Bug 167107 - [GTK] [MSE] Turn MSE on by default
Summary: [GTK] [MSE] Turn MSE on by default
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Michael Catanzaro
URL:
Keywords:
: 180233 (view as bug list)
Depends on: 165394 167108 99065 167120
Blocks: 131313
  Show dependency treegraph
 
Reported: 2017-01-16 18:54 PST by Carlos Alberto Lopez Perez
Modified: 2017-12-01 10:33 PST (History)
10 users (show)

See Also:


Attachments
Patch (3.70 KB, patch)
2017-12-01 09:53 PST, Michael Catanzaro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2017-01-16 18:54:56 PST
All WebKit ports are enabling MSE by default since 2014. See bug 131313.

MSE is needed (among other things) for having 1080p (or superior quality) video on Youtube.

With WebKitGTK+ trunk:

$ Tools/Scripts/run-minibrowser --gtk --release  https://www.youtube.com/watch?v=iNJdPyoqt8U
(only 720p available)

$ Tools/Scripts/run-minibrowser --gtk --release --enable-mediasource=true https://www.youtube.com/watch?v=iNJdPyoqt8U
(1080p and 4k available)

Is there any reason why we are still not shipping this by default??
Comment 1 Michael Catanzaro 2017-01-16 20:00:45 PST
(Do we need WebM support before we can turn it on, or does YouTube gracefully degrade to non-MSE when encumbered codecs are unavailable?)
Comment 2 Carlos Alberto Lopez Perez 2017-01-17 09:37:13 PST
(In reply to comment #1)
> (Do we need WebM support before we can turn it on, or does YouTube
> gracefully degrade to non-MSE when encumbered codecs are unavailable?)

No, it just crashes ;)

See bug 167120
Comment 3 Michael Catanzaro 2017-07-25 13:28:29 PDT
(In reply to Carlos Alberto Lopez Perez from comment #0)
> All WebKit ports are enabling MSE by default since 2014. See bug 131313.
> 
> MSE is needed (among other things) for having 1080p (or superior quality)
> video on Youtube.

On Fedora, we are currently limited to 360p quality video on YouTube. MSE is required to get 480p, 720p and 1080p when H.264 is not supported.

On platforms which include H.264 support, the max is indeed 720p without MSE, so the need for MSE is much less urgent.
Comment 4 Carlos Alberto Lopez Perez 2017-12-01 05:30:37 PST
*** Bug 180233 has been marked as a duplicate of this bug. ***
Comment 5 Michael Catanzaro 2017-12-01 09:53:11 PST
Created attachment 328109 [details]
Patch
Comment 6 WebKit Commit Bot 2017-12-01 10:33:20 PST
Comment on attachment 328109 [details]
Patch

Clearing flags on attachment: 328109

Committed r225400: <https://trac.webkit.org/changeset/225400>
Comment 7 WebKit Commit Bot 2017-12-01 10:33:21 PST
All reviewed patches have been landed.  Closing bug.