Bug 16706 - CSS3: "#div1 ~ div div + div > div" fails to update after dom change (Acid3 bug)
Summary: CSS3: "#div1 ~ div div + div > div" fails to update after dom change (Acid3 bug)
Status: RESOLVED DUPLICATE of bug 11384
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: NeedsReduction
Depends on:
Blocks: Acid3
  Show dependency treegraph
 
Reported: 2008-01-01 22:21 PST by Eric Seidel (no email)
Modified: 2008-01-29 04:42 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2008-01-01 22:21:18 PST
CSS3: "#div1 ~ div div + div > div" fails to update after dom change (Acid3 bug)

    function () {
      // test 41: +, ~, >, and ' ' in dynamic situations
      selectorTest(function (doc, add, expect) {
        var div1 = doc.createElement('div');
        div1.id = "div1";
        doc.body.appendChild(div1);
        var div2 = doc.createElement('div');
        doc.body.appendChild(div2);
        var div3 = doc.createElement('div');
        doc.body.appendChild(div3);
        var div31 = doc.createElement('div');
        div3.appendChild(div31);
        var div311 = doc.createElement('div');
        div31.appendChild(div311);
        var div3111 = doc.createElement('div');
        div311.appendChild(div3111);
        var match = add("#div1 ~ div div + div > div");
        expect(div1, 0, "failure 1");
        expect(div2, 0, "failure 2");
        expect(div3, 0, "failure 3");
        expect(div31, 0, "failure 4");
        expect(div311, 0, "failure 5");
        expect(div3111, 0, "failure 6");
        var div310 = doc.createElement('div');
        div31.insertBefore(div310, div311);
        expect(div1, 0, "failure 7");
        expect(div2, 0, "failure 8");
        expect(div3, 0, "failure 9");
        expect(div31, 0, "failure 10");
        expect(div310, 0, "failure 11");
        expect(div311, 0, "failure 12");
        expect(div3111, match, "rule did not start matching after change");
      });

We fail the last expect:
expect(div3111, match, "rule did not start matching after change");
Comment 1 Robert Blaut 2008-01-28 08:25:58 PST
I think it's a duplication of a bug 11384, isn't it?
Comment 2 Robert Blaut 2008-01-29 04:42:37 PST

*** This bug has been marked as a duplicate of 11384 ***