Bug 166924 - [GTK] Ephiphany tabs hang randomly
Summary: [GTK] Ephiphany tabs hang randomly
Status: RESOLVED DUPLICATE of bug 167688
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Local Build
Hardware: PC Linux
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-11 05:47 PST by Xabier Rodríguez Calvar
Modified: 2017-02-13 07:39 PST (History)
5 users (show)

See Also:


Attachments
Backtrace (66.42 KB, text/plain)
2017-01-11 05:47 PST, Xabier Rodríguez Calvar
no flags Details
Another backtrace (21.18 KB, text/plain)
2017-01-11 05:50 PST, Xabier Rodríguez Calvar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xabier Rodríguez Calvar 2017-01-11 05:47:33 PST
Created attachment 298572 [details]
Backtrace

Running the web app of wunderlist.com, after some time I got the tab frozen. Backtrace is attached
Comment 1 Xabier Rodríguez Calvar 2017-01-11 05:50:03 PST
Created attachment 298573 [details]
Another backtrace

The funny thing is that as I was reporting the bug the first time, while selecting components and priorities, that new tab got stuck too.
Comment 2 Xabier Rodríguez Calvar 2017-01-11 05:51:28 PST
I forgot to say that Webkit was built against GNOME jhbuild of Jan 8th 2017, all master and the version was 2.15.2.
Comment 3 Miguel Gomez 2017-02-13 06:18:05 PST
I think this is the same issue than bug 167688.

They are 2 bugs actually, one happening with DRI3 and another one with DRI2.

Something very similar to the DRI3 was reported here https://bugs.freedesktop.org/show_bug.cgi?id=84252
but it seems to be already fixed for versions of libxcb higher than 1.11-something (depending on the distro). Seems to be fixed in 1.11-8 in fedora and the debian versions 1-11-1 seems tho have the fix as well.

Regarding the DRI2, there's this one still open https://bugs.freedesktop.org/show_bug.cgi?id=94108 which is probably related.

I any case, it doesn't seem to be related to webkit, but some lower layer.
Comment 4 Michael Catanzaro 2017-02-13 07:39:23 PST
OK. Let's mark this as the duplicate, because there are better backtraces in bug #167688.

*** This bug has been marked as a duplicate of bug 167688 ***