Bug 166908 - Web Inspector: Network tab: provide a way to preserve log on navigation
Summary: Web Inspector: Network tab: provide a way to preserve log on navigation
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
: 114232 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-10 16:05 PST by Nikita Vasilyev
Modified: 2017-02-06 14:33 PST (History)
6 users (show)

See Also:


Attachments
Patch (4.75 KB, patch)
2017-01-30 15:18 PST, Devin Rousso
no flags Details | Formatted Diff | Diff
[Image] Dimmed network rows (499.98 KB, image/png)
2017-01-31 11:57 PST, Matt Baker
no flags Details
Patch (9.88 KB, patch)
2017-01-31 12:55 PST, Devin Rousso
no flags Details | Formatted Diff | Diff
[Image] After Patch is applied (253.26 KB, image/png)
2017-01-31 12:55 PST, Devin Rousso
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Vasilyev 2017-01-10 16:05:30 PST
Currently, network tab gets cleared on main resource navigation.

Preserving log on navigation is very helpful when debugging redirects.
Comment 1 Radar WebKit Bug Importer 2017-01-10 16:06:08 PST
<rdar://problem/29958216>
Comment 2 Devin Rousso 2017-01-30 15:18:29 PST
Created attachment 300148 [details]
Patch
Comment 3 Nikita Vasilyev 2017-01-30 15:54:15 PST
This looks like a good first step.

When navigating from page A to page B, there's no easy way to see which resources loaded on which page. It would be nice to have a horizontal divider in the data grid between previous and current page loads. The dividers may look similar to what we use in the console https://bugs.webkit.org/show_bug.cgi?id=161938#c3.
Comment 4 Devin Rousso 2017-01-30 18:09:50 PST
(In reply to comment #3)
> This looks like a good first step.
> 
> When navigating from page A to page B, there's no easy way to see which
> resources loaded on which page. It would be nice to have a horizontal
> divider in the data grid between previous and current page loads. The
> dividers may look similar to what we use in the console
> https://bugs.webkit.org/show_bug.cgi?id=161938#c3.

I definitely agree that this would be nice, but I'm trying to piece through the WI.TimelineDataGrid code right now and it is very dense.  I'm not sure if I am the best person to attempt doing this.

From what I can see so far, it seems like there would need to be some sort of "TitleDataGridNode" that spans multiple columns (via the `colspan` attribute maybe), but either it would also have to implement all of the additional WI.TimelineDataGridNode functions or some logic would need to be added to WI.TimelineDataGrid to ignore instances of "TimelineDataGridNode" when calling certain functions.  Additionally, something would have to be done in WI.NetworkSidebarPanel, but that is just a tree, so it should be a lot easier.

Any tips/pointers would be greatly appreciated.
Comment 5 Matt Baker 2017-01-31 11:56:36 PST
(In reply to comment #4)
> (In reply to comment #3)
> > This looks like a good first step.
> > 
> > When navigating from page A to page B, there's no easy way to see which
> > resources loaded on which page. It would be nice to have a horizontal
> > divider in the data grid between previous and current page loads. The
> > dividers may look similar to what we use in the console
> > https://bugs.webkit.org/show_bug.cgi?id=161938#c3.
> 
> I definitely agree that this would be nice, but I'm trying to piece through
> the WI.TimelineDataGrid code right now and it is very dense.  I'm not sure
> if I am the best person to attempt doing this.
> 
> From what I can see so far, it seems like there would need to be some sort
> of "TitleDataGridNode" that spans multiple columns (via the `colspan`
> attribute maybe), but either it would also have to implement all of the
> additional WI.TimelineDataGridNode functions or some logic would need to be
> added to WI.TimelineDataGrid to ignore instances of "TimelineDataGridNode"
> when calling certain functions.  Additionally, something would have to be
> done in WI.NetworkSidebarPanel, but that is just a tree, so it should be a
> lot easier.
> 
> Any tips/pointers would be greatly appreciated.

I think an alternative approach would be preferable. A visual divider in the grid will be awkward to implement, as you've already mentioned. Would it be enough to just style all or part of the grid node text differently?
Comment 6 Matt Baker 2017-01-31 11:57:20 PST
Created attachment 300244 [details]
[Image] Dimmed network rows

Quick photoshop mockup
Comment 7 Devin Rousso 2017-01-31 12:55:34 PST
Created attachment 300250 [details]
Patch
Comment 8 Devin Rousso 2017-01-31 12:55:54 PST
Created attachment 300251 [details]
[Image] After Patch is applied
Comment 9 Matt Baker 2017-01-31 13:15:29 PST
(In reply to comment #8)
> Created attachment 300251 [details]
> [Image] After Patch is applied

I think I like it. Styling a "previous" item's icon with normal saturation when selected is a nice touch.
Comment 10 Matt Baker 2017-01-31 13:22:17 PST
The graph node should have normal saturation when the row is selected. It will be very hard to distinguish between desaturated bar segments when more timing data is shown.
Comment 11 Devin Rousso 2017-01-31 13:56:16 PST
(In reply to comment #10)
> The graph node should have normal saturation when the row is selected. It
> will be very hard to distinguish between desaturated bar segments when more
> timing data is shown.

I just realized that it's hard to see in the screenshot, but it actually does this already :D
Comment 12 Matt Baker 2017-01-31 13:59:45 PST
(In reply to comment #11)
> (In reply to comment #10)
> > The graph node should have normal saturation when the row is selected. It
> > will be very hard to distinguish between desaturated bar segments when more
> > timing data is shown.
> 
> I just realized that it's hard to see in the screenshot, but it actually
> does this already :D

Hah, I thought that might be the case.
Comment 13 Matt Baker 2017-01-31 14:57:46 PST
Comment on attachment 300250 [details]
Patch

We may want to revisit the row styles eventually, and dim icons in preserved rows even when selected. if the selected row is the last (or only) preserved row it's visually indistinguishable from the first non-preserved row.

For now this helps to distinguish preserved rows.
Comment 14 WebKit Commit Bot 2017-01-31 15:24:21 PST
Comment on attachment 300250 [details]
Patch

Clearing flags on attachment: 300250

Committed r211451: <http://trac.webkit.org/changeset/211451>
Comment 15 WebKit Commit Bot 2017-01-31 15:24:25 PST
All reviewed patches have been landed.  Closing bug.
Comment 16 Brian Burg 2017-02-06 14:33:50 PST
*** Bug 114232 has been marked as a duplicate of this bug. ***