Bug 16686 - [GTK] Add DOM accessors to WebView/WebFrame
: [GTK] Add DOM accessors to WebView/WebFrame
Status: RESOLVED DUPLICATE of bug 16401
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk
: 528+ (Nightly build)
: PC Linux
: P3 Enhancement
Assigned To: Nobody
: Gtk
Depends on: 16401
  Show dependency treegraph
Reported: 2007-12-31 08:14 PST by Mathias Roth
Modified: 2009-04-14 05:44 PDT (History)
4 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Roth 2007-12-31 08:14:52 PST
I'm currently implementing Adium-Messagestyles to a messenging application using pywebkitgtk, but I don't see any easy way to add new messages to the WebView without rerendering the whole HTML. I'd like to see some DOM-Functions that make it possible to use code similiar to Kopete's (another Chat-Application supporting Adium-Messagestyles, using KHTML).
Here's a code-snippet from Kopete that pretty much describes what I'd like to have: http://pastebin.ca/839983
Comment 1 David Kilzer (:ddkilzer) 2007-12-31 10:50:43 PST
The OS X version of WebKit has a DOM API written in Objective-C that's generated from *.idl files.  A generator for a C or C++ API would be one approach.

Comment 2 Luke Kenneth Casson Leighton 2008-08-20 16:25:10 PDT

i'm covering events as well.  it's not ideal: it's done using
javascript snippets right now.
Comment 3 Gustavo Noronha (kov) 2009-04-14 05:44:14 PDT
I think this can safely be marked as a duplicate.

*** This bug has been marked as a duplicate of 16401 ***