Bug 166838 - [GTK] WebProcess from WebKitGtk+ 2.15.x SIGSEGVs in GIFLZWContext::outputRow() at Source/WebCore/platform/image-decoders/gif/GIFImageReader.cpp:150
Summary: [GTK] WebProcess from WebKitGtk+ 2.15.x SIGSEGVs in GIFLZWContext::outputRow(...
Status: RESOLVED DUPLICATE of bug 169199
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Local Build
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-09 04:54 PST by Andres Gomez Garcia
Modified: 2017-03-06 10:29 PST (History)
2 users (show)

See Also:


Attachments
BT from gdb (222.59 KB, text/plain)
2017-01-09 04:54 PST, Andres Gomez Garcia
no flags Details
Another similar BT from gdb (239.21 KB, text/plain)
2017-01-13 04:23 PST, Andres Gomez Garcia
no flags Details
Yet another similar BT from gdb (304.92 KB, text/plain)
2017-01-13 04:24 PST, Andres Gomez Garcia
no flags Details
BT from gdb for the WebProcess, 2.15.4 (230.65 KB, text/plain)
2017-02-01 07:23 PST, Andres Gomez Garcia
no flags Details
BT from gdb for epiphany's WebApp (230.65 KB, text/plain)
2017-02-02 00:57 PST, Andres Gomez Garcia
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Gomez Garcia 2017-01-09 04:54:05 PST
Created attachment 298341 [details]
BT from gdb

I'm using WebKitGtk+ with my own JHBuild setting:
https://github.com/tanty/jhbuild-epiphany/tree/master

Epiphany 3.20.3 and WebKit 2.15.2 with the attached patches for bug 164049, bug 165200, bug 165283, bug 164052 and bug 165848, applied.

I'm running Epiphany with the dconf key:

"process-model" = "shared-secondary-process"

And the env variable:

"export LIBGL_DRI3_DISABLE=1"

The compilation was done with CMake args:

'-DENABLE_THREADED_COMPOSITOR=OFF -DPORT=GTK -DCMAKE_BUILD_TYPE=Release -DENABLE_MINIBROWSER=ON -DCMAKE_C_FLAGS_RELEASE="-O0 -g1 -DNDEBUG -DG_DEBUG=fatal-criticals -DG_DISABLE_CAST_CHECKS" -DCMAKE_CXX_FLAGS_RELEASE="-O0 -g1 -DNDEBUG -DG_DEBUG=fatal-criticals -DG_DISABLE_CAST_CHECKS"'

After visiting several pages, eventually, the WebProcess hits a SIGSEV.

This bug is not reproducible in a predictable way.
Comment 1 Andres Gomez Garcia 2017-01-13 04:23:13 PST
Created attachment 298753 [details]
Another similar BT from gdb
Comment 2 Andres Gomez Garcia 2017-01-13 04:24:30 PST
Created attachment 298754 [details]
Yet another similar BT from gdb
Comment 3 Andres Gomez Garcia 2017-02-01 07:23:45 PST
Created attachment 300324 [details]
BT from gdb for the WebProcess, 2.15.4

Still reproducible with Epiphany 3.22.5 and WebKit 2.15.4.

I'm running Epiphany with the dconf key:

"process-model" = "shared-secondary-process"

And the env variable:

"export G_DEBUG=fatal-criticals"

The compilation was done with CMake args:

'-DENABLE_THREADED_COMPOSITOR=OFF -DPORT=GTK -DCMAKE_BUILD_TYPE=Release -DENABLE_MINIBROWSER=ON -DCMAKE_C_FLAGS_RELEASE="-O0 -g1 -DNDEBUG  -DG_DISABLE_CAST_CHECKS" -DCMAKE_CXX_FLAGS_RELEASE="-O0 -g1 -DNDEBUG -DG_DISABLE_CAST_CHECKS"'
Comment 4 Andres Gomez Garcia 2017-02-02 00:57:19 PST
Created attachment 300393 [details]
BT from gdb for epiphany's WebApp

Not exactly the same problem, but in case they are co-related and this can help to solve the problem(s).

Running an Ephy WebApp with WKGTK+ 2.15.4, with:

G_DEBUG=fatal-criticals

and with the arguments:

--application-mode --profile="/home/tanty/.config/epiphany/app-epiphany-facebook-82da67b211249624f24f3c7db5642a5112c9446f" https://www.facebook.com/
Comment 5 Michael Catanzaro 2017-03-06 10:29:57 PST

*** This bug has been marked as a duplicate of bug 169199 ***