Bug 16671 - Additional box at bottom of united.com
Summary: Additional box at bottom of united.com
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.united.com/
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2007-12-30 00:16 PST by Gavin Sherlock
Modified: 2010-02-16 17:34 PST (History)
4 users (show)

See Also:


Attachments
screenshot showing oddity on bottom left (351.49 KB, image/png)
2007-12-30 00:18 PST, Gavin Sherlock
no flags Details
Reduction for bug number 16671 (541 bytes, text/html)
2008-02-05 21:16 PST, Sam Stigler
no flags Details
Snapshot from Mac Mini (125.65 KB, image/gif)
2008-07-18 01:21 PDT, Robert Blaut
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Sherlock 2007-12-30 00:16:49 PST
Go to http://www.united.com/ - note odd box at the bottom of the page.  If you make the page wider, this stays left justified.  Not sure if this is a regression, but it does not appear in Firefox.  Tested with r28979 on 10.5.1
Comment 1 Gavin Sherlock 2007-12-30 00:18:09 PST
Created attachment 18181 [details]
screenshot showing oddity on bottom left
Comment 2 David Kilzer (:ddkilzer) 2007-12-30 07:48:45 PST
Confirmed with Safari 3.0.4 (523.12.2) with original WebKit on Mac OS X 10.4.11 (8S165).  Also occurs with a local debug build of WebKit r29032.

Comment 3 mitz 2007-12-30 08:48:16 PST
Its a <div id="tooltip">, present in Firefox as well but in WebKit it has style="" whereas in Firefox it has style="display: none".
Comment 4 Sam Stigler 2008-02-05 21:13:27 PST
I've been able to reduce this to something related to their use of a jQuery tooltip.  It's very odd; just having the tooltip style declared and initializing the Tooltip causes the the box to appear.  Removing the initialization will also remove the box.  I'm attaching the reduction.
Comment 5 Sam Stigler 2008-02-05 21:15:36 PST
Forgot to note: Tested on r30028, on Mac OS X 10.5.1.
Comment 6 Sam Stigler 2008-02-05 21:16:44 PST
Created attachment 18950 [details]
Reduction for bug number 16671
Comment 7 Chasen Le Hara 2008-02-06 12:13:24 PST
While creating a reduction I found this in the changelog for the tooltip plugin utilized in the current reduction:

"1.2
---
* Fixed bug in Safari 3 where to tooltip is initially visible, by first appending to DOM then hiding it"

So, the plugin author fixed this bug in a later release than what's being used on united.com. Do we want to further explore this bug?
Comment 8 Robert Blaut 2008-02-07 06:09:56 PST
It's definitely Evangelism bug since changing user agent to Firefox fixes the problem.
Comment 9 mitz 2008-02-07 07:43:23 PST
<rdar://problem/5729732>
Comment 10 Robert Blaut 2008-07-17 00:54:51 PDT
As I tested today the bottom box isn't visible on the page any more. Tested with Webkit r35203.
Comment 11 Gavin Sherlock 2008-07-17 07:55:47 PDT
It's definitely still there with r35203 on Mac.  What platform did you test on?
Comment 12 Robert Blaut 2008-07-18 01:21:30 PDT
Created attachment 22356 [details]
Snapshot from Mac Mini

(In reply to comment #11)
> It's definitely still there with r35203 on Mac.  What platform did you test on?
> 

It's strange bug as I tested the site yesterday and also today on my Mac Mini the box isn't visible (screenshot attached). But it's visible on my other machine - Macbook. Strange.
Comment 13 mitz 2010-02-16 17:34:34 PST
Seems to be fixed now.