Bug 16591 - hover issue with menus at www.multicians.org
Summary: hover issue with menus at www.multicians.org
Status: RESOLVED DUPLICATE of bug 7555
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.multicians.org/
Keywords: NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-12-23 15:33 PST by Tom Van Vleck
Modified: 2008-03-11 11:55 PDT (History)
2 users (show)

See Also:


Attachments
Partial reduction (2.21 KB, text/html)
2007-12-23 22:09 PST, David Kilzer (:ddkilzer)
no flags Details
Further reduction (379 bytes, text/html)
2007-12-28 00:19 PST, Eric Seidel (no email)
no flags Details
Test case (320 bytes, text/html)
2008-03-11 11:54 PDT, Chasen Le Hara
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Van Vleck 2007-12-23 15:33:22 PST
Hovering over "Artifacts" and "Stories" correctly reveals a menu, but hovering over the menu lines does not reveal a second level menu, as it does in Safari 2 and Firefox.

The second level menus have display: none but are supposed to change to display: block when hovered, e.g.
     #headpagenavbox td:hover ul,
     #headpagenavbox tr li:hover ul,
     #headpagenavbox tr li a:hover ul,
     #headpagenavbox tr ul li:hover ul,
     #headpagenavbox tr ul ul li:hover ul,
     #headpagenavbox tr ul ul ul li:hover ul{display:block;}
Comment 1 David Kilzer (:ddkilzer) 2007-12-23 16:23:05 PST
Confirmed with Safari 3.0.4 (523.12) with original WebKit on Mac OS X 10.4.11 (8S165).

Comment 2 David Kilzer (:ddkilzer) 2007-12-23 16:31:05 PST
Also verified with a local debug build of WebKit r28968 with Safari 3.0.4 (523.12) on Mac OS X 10.4.11 (8S165).

Comment 3 mitz 2007-12-23 17:53:21 PST
P1/Regression based on working in Safari 2.
Comment 4 David Kilzer (:ddkilzer) 2007-12-23 22:09:04 PST
Created attachment 18087 [details]
Partial reduction

Partial reduction of the issue.  Looking at this reduction in Firefox 2, node highlighting is different in addition to the second-level <ul> not showing up.

May be related to Bug 7555 and/or Bug 9279.
Comment 5 Eric Seidel (no email) 2007-12-28 00:19:04 PST
Created attachment 18142 [details]
Further reduction

Still not quite a complete reduction
Comment 6 Eric Seidel (no email) 2007-12-28 00:21:58 PST
Interesting, removing the rule:
#top li:hover { display: block; }
fixes things.

Still investigating.
Comment 7 Chasen Le Hara 2008-03-11 11:54:12 PDT
Created attachment 19671 [details]
Test case

This bug shows up when the display value changes on a state change (hover, active, etc.; this test case tests hover).
Comment 8 mitz 2008-03-11 11:55:35 PDT
(In reply to comment #7)
> This bug shows up when the display value changes on a state change (hover,
> active, etc.; this test case tests hover).

Good ol' bug 7555!

*** This bug has been marked as a duplicate of 7555 ***