WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
165006
[css-grid] Isolate size of internal representation from actual grid size
https://bugs.webkit.org/show_bug.cgi?id=165006
Summary
[css-grid] Isolate size of internal representation from actual grid size
Sergio Villar Senin
Reported
2016-11-21 03:08:50 PST
[css-grid] Isolate size of internal representation from actual grid size
Attachments
Patch
(7.24 KB, patch)
2016-11-21 03:13 PST
,
Sergio Villar Senin
no flags
Details
Formatted Diff
Diff
Patch
(7.45 KB, patch)
2016-11-22 02:29 PST
,
Sergio Villar Senin
rego
: review+
Details
Formatted Diff
Diff
Show Obsolete
(1)
View All
Add attachment
proposed patch, testcase, etc.
Sergio Villar Senin
Comment 1
2016-11-21 03:13:58 PST
Created
attachment 295289
[details]
Patch
Javier Fernandez
Comment 2
2016-11-21 03:31:30 PST
Comment on
attachment 295289
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=295289&action=review
In the ChangeLog it's explained very well the problem, but not so clear, IMO, why this patch solves the issue. I'd add some lines to show that we have now 2 different functions to get the size of the grid, one using the pysical representation and the other one, using the logical one. Other than that, the change looks good.
> Source/WebCore/ChangeLog:13 > + memory allocations are done to create a grid representation it as it is not needed.
typo: "representation *it as it*" -> "representation *as it*
Sergio Villar Senin
Comment 3
2016-11-22 02:29:02 PST
Created
attachment 295333
[details]
Patch
Javier Fernandez
Comment 4
2016-11-22 02:47:47 PST
Comment on
attachment 295333
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=295333&action=review
> Source/WebCore/rendering/RenderGrid.cpp:2713 > +unsigned RenderGrid::numTracks(GridTrackSizingDirection direction) const
As we talked privately, what do you think about figuring out a more descriptive name for this function and the one we already have, gridColumnCount ? The difference between them is not obvious at all.
Sergio Villar Senin
Comment 5
2016-11-22 03:13:43 PST
(In reply to
comment #4
)
> Comment on
attachment 295333
[details]
> Patch > > View in context: >
https://bugs.webkit.org/attachment.cgi?id=295333&action=review
> > > Source/WebCore/rendering/RenderGrid.cpp:2713 > > +unsigned RenderGrid::numTracks(GridTrackSizingDirection direction) const > > As we talked privately, what do you think about figuring out a more > descriptive name for this function and the one we already have, > gridColumnCount ? The difference between them is not obvious at all.
Right, I agree the names are not very good, but I'd prefer to change them later after finishing the refactoring if you don't feel strongly about it (I have a lot of dependent patches in my queue, so this kind of changes will force me to do a lot of conflict resolution).
Javier Fernandez
Comment 6
2016-11-22 04:16:09 PST
(In reply to
comment #5
)
> (In reply to
comment #4
) > > Comment on
attachment 295333
[details]
> > Patch > > > > View in context: > >
https://bugs.webkit.org/attachment.cgi?id=295333&action=review
> > > > > Source/WebCore/rendering/RenderGrid.cpp:2713 > > > +unsigned RenderGrid::numTracks(GridTrackSizingDirection direction) const > > > > As we talked privately, what do you think about figuring out a more > > descriptive name for this function and the one we already have, > > gridColumnCount ? The difference between them is not obvious at all. > > Right, I agree the names are not very good, but I'd prefer to change them > later after finishing the refactoring if you don't feel strongly about it (I > have a lot of dependent patches in my queue, so this kind of changes will > force me to do a lot of conflict resolution).
Sure, no problem with waiting until the refactoring is completed.
Manuel Rego Casasnovas
Comment 7
2016-11-22 04:20:45 PST
Comment on
attachment 295333
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=295333&action=review
LGTM.
> Source/WebCore/rendering/RenderGrid.h:195 > unsigned gridColumnCount() const; > unsigned gridRowCount() const; > + unsigned numTracks(GridTrackSizingDirection) const;
I'd add a FIXME on these 3 methods to look for better names once the refactoring is done.
Sergio Villar Senin
Comment 8
2016-11-22 06:35:17 PST
Committed
r208962
: <
http://trac.webkit.org/changeset/208962
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug