Bug 16481 - WebKit fails WICD SVG background image tests
Summary: WebKit fails WICD SVG background image tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 15836
  Show dependency treegraph
 
Reported: 2007-12-17 14:29 PST by Eric Seidel (no email)
Modified: 2011-05-29 07:41 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 2 Beth Dakin 2007-12-17 14:35:34 PST
The SVGs used in these tests do not have any size values on the SVG tag itself. I imagine that is the problem. 
Comment 3 Eric Seidel (no email) 2007-12-17 16:33:28 PST
I see fast/images/svg-width-100p-as-background.html failing for me as well (when I open it in Safari, I've not tried running it with --pixel), which would suggest that relative size SVG images aren't working on TOT.
Comment 4 Nikolas Zimmermann 2011-05-27 23:50:06 PDT
These testcases work in trunk since a while, have not checked exactly since when.
I'm going to land them as new testcases in svg/wicd.
Comment 5 Nikolas Zimmermann 2011-05-27 23:52:37 PDT
Landed new tests in r87605.
Comment 6 Dirk Schulze 2011-05-28 00:10:26 PDT
Test cases should get reviewed as well.
Comment 7 Nikolas Zimmermann 2011-05-28 00:47:07 PDT
(In reply to comment #6)
> Test cases should get reviewed as well.

Even if I didn't construct them? I used to land testcases like this w/o review in the past.
Comment 8 Eric Seidel (no email) 2011-05-29 07:41:01 PDT
Reviews are always a good thing.  I don't know what the exact policy states.