It's completely the same.
(In reply to comment #0) > It's completely the same. Lol. FWIW, I prefer the name "SetForScope" over "TemporaryChange"
Created attachment 295033 [details] Patch
Created attachment 295035 [details] Patch
Created attachment 295038 [details] Patch
Comment on attachment 295038 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=295038&action=review r=me > Source/WTF/wtf/SetForScope.h:51 > + SetForScope(T& scopedVariable, T newValue) Might be nice to use forward semantics here. > Source/WTF/wtf/SetForScope.h:59 > + m_scopedVariable = m_originalValue; Maybe move semantics?
Comment on attachment 295038 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=295038&action=review Thanks! >> Source/WTF/wtf/SetForScope.h:51 >> + SetForScope(T& scopedVariable, T newValue) > > Might be nice to use forward semantics here. Yeah, fixed. Using argument deduction and std::forward here. >> Source/WTF/wtf/SetForScope.h:59 >> + m_scopedVariable = m_originalValue; > > Maybe move semantics? Yeah, we can use `WTFMove()`.
Committed r208841: <http://trac.webkit.org/changeset/208841>
I think this rename should have been communicated with webkit-dev.
(In reply to comment #8) > I think this rename should have been communicated with webkit-dev. Fair enough. We can always name it back.
(In reply to comment #9) > (In reply to comment #8) > > I think this rename should have been communicated with webkit-dev. > > Fair enough. We can always name it back. I'll send out an email to webkit-dev now.
Would have also been nice to have some discussion about naming. This comes through as picking the JSC name by fiat.