Bug 164747 - Update SubtleCrypto::unwrapKey to match the latest spec
Summary: Update SubtleCrypto::unwrapKey to match the latest spec
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jiewen Tan
URL:
Keywords: InRadar
Depends on:
Blocks: 160883
  Show dependency treegraph
 
Reported: 2016-11-14 16:01 PST by Jiewen Tan
Modified: 2016-12-01 13:45 PST (History)
8 users (show)

See Also:


Attachments
Patch (67.07 KB, patch)
2016-11-30 17:41 PST, Jiewen Tan
no flags Details | Formatted Diff | Diff
Patch (67.04 KB, patch)
2016-12-01 12:22 PST, Jiewen Tan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jiewen Tan 2016-11-14 16:01:18 PST
Update SubtleCrypto::unwrapKey to match the latest spec.
Comment 1 Radar WebKit Bug Importer 2016-11-14 16:54:00 PST
<rdar://problem/29258198>
Comment 2 Jiewen Tan 2016-11-30 17:41:06 PST
Created attachment 295801 [details]
Patch
Comment 3 WebKit Commit Bot 2016-11-30 17:44:06 PST
Attachment 295801 [details] did not pass style-queue:


ERROR: Source/WebCore/crypto/algorithms/CryptoAlgorithmAES_KW.cpp:170:  CryptoAlgorithmAES_KW::unwrapKey is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/crypto/gnutls/CryptoAlgorithmAES_KWGnuTLS.cpp:41:  CryptoAlgorithmAES_KW::platformUnwrapKey is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/crypto/mac/CryptoAlgorithmAES_KWMac.cpp:52:  unwrapKeyAES_KW is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/crypto/mac/CryptoAlgorithmAES_KWMac.cpp:78:  CryptoAlgorithmAES_KW::platformUnwrapKey is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 4 in 33 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Jiewen Tan 2016-12-01 12:22:00 PST
Created attachment 295875 [details]
Patch
Comment 5 WebKit Commit Bot 2016-12-01 12:24:56 PST
Attachment 295875 [details] did not pass style-queue:


ERROR: Source/WebCore/crypto/algorithms/CryptoAlgorithmAES_KW.cpp:170:  CryptoAlgorithmAES_KW::unwrapKey is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/crypto/gnutls/CryptoAlgorithmAES_KWGnuTLS.cpp:41:  CryptoAlgorithmAES_KW::platformUnwrapKey is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/crypto/mac/CryptoAlgorithmAES_KWMac.cpp:52:  unwrapKeyAES_KW is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/WebCore/crypto/mac/CryptoAlgorithmAES_KWMac.cpp:78:  CryptoAlgorithmAES_KW::platformUnwrapKey is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 4 in 33 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Brent Fulgham 2016-12-01 12:35:50 PST
Comment on attachment 295875 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=295875&action=review

Looks good!

> Source/WebCore/bindings/js/JSSubtleCryptoCustom.cpp:940
> +        // The following operation should be performed asynchronously.

Is this a note to remind you to do something in the future?
Comment 7 Jiewen Tan 2016-12-01 12:38:29 PST
Comment on attachment 295875 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=295875&action=review

Thanks Brent for r+ my patch.

>> Source/WebCore/bindings/js/JSSubtleCryptoCustom.cpp:940
>> +        // The following operation should be performed asynchronously.
> 
> Is this a note to remind you to do something in the future?

Not really. It is a note to remind me of whether the following operation will be executed asynchronously/synchronously.
Comment 8 WebKit Commit Bot 2016-12-01 13:45:52 PST
Comment on attachment 295875 [details]
Patch

Clearing flags on attachment: 295875

Committed r209200: <http://trac.webkit.org/changeset/209200>
Comment 9 WebKit Commit Bot 2016-12-01 13:45:57 PST
All reviewed patches have been landed.  Closing bug.