Bug 16474 - WebKit should support native Image capture controls
: WebKit should support native Image capture controls
Status: RESOLVED DUPLICATE of bug 43239
: WebKit
New Bugs
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Enhancement
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-12-17 05:39 PST by
Modified: 2010-08-06 09:40 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-12-17 05:39:52 PST
a range of possibilities including:
uploading images
presence in game: photo of me in webpage or game, locally only.
input device: using motion detection
------- Comment #1 From 2007-12-17 05:42:02 PST -------
Um.  I think the place to start with a request like this is for something "simple", like a <input type=file> control which was specific to image capture.  <input type="file" capture="still"> would be one thought.  I'm sure many many others on the web have already discussed this at some length.
------- Comment #2 From 2007-12-17 05:49:03 PST -------
http://tinyurl.com/3x95vt
how to implement: developer.apple.com
------- Comment #3 From 2007-12-17 06:25:04 PST -------
I don't think there's anything very actionable about this bug as the feature request is so vague.
------- Comment #4 From 2007-12-17 09:01:45 PST -------
http://lists.w3.org/Archives/Public/public-webapi/2007Dec/0056.html

a request to Doug & Chaals who have some understanding of the issue.
------- Comment #5 From 2007-12-18 05:26:40 PST -------
filed 2 radar enhancement bugs related to this bug

#5653025 iSight internal: URI & unique local URI
it would be helpful if there was a simple way to link to the internal iSight
camera.
web pages and dashboard widgets could then involve the user.
this would require a simple unique uri that was common to all macs such as:
file:///iSight.jpg or similar

and also a variation for serving on the web similar to:
http://peepo.getmyip.com/~JonathanChetwynd/zanadu.svg
but more likely
http://peepo.getmyip.com/~JonathanChetwynd/iSight.jpg


#5653030 iSight internal: motion detection
keyword: Accessibility
gesture is a vital skill.
the internal camera has the potential to be a useful input device.
motion detection offers the opportunity to control and move the cursor by
gesture.
------- Comment #6 From 2010-08-06 09:40:59 PST -------
It looks like a specification known as the Capture API is emerging. It appears to cover this use case and more. I'm marking this as a duplicate of that bug.

*** This bug has been marked as a duplicate of bug 43239 ***