Bug 16429 - WebKit nightlies no longer dispatch keypress for special keys
: WebKit nightlies no longer dispatch keypress for special keys
Status: RESOLVED INVALID
Product: WebKit
Classification: Unclassified
Component: WebKit Misc.
: 528+ (Nightly build)
: Macintosh Intel Mac OS X 10.5
: P2 Major
Assigned To: Nobody
http://unixpapa.com/js/testkey.html
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 17:13 PST by Eric Naeseth
Modified: 2013-02-06 18:39 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Naeseth 2007-12-13 17:13:42 PST
While WebKit r28669 (unlike Safari 3.0.4) now dispatches keydown/keyup events for modifier keys (Shift, Control, Option, and Command), it no longer dispatches keypress events for those keys and the "special" keys it previously dispatched them for (namely the arrow keys, home, end, page up and down, tab, delete, and backspace). It still dispatches one for Enter, but its keyIdentifier field is now blank (previously it was "Enter".)

A useful page for testing this behavior has been provided as this bug's URL.

This may have been intentional (after all, the old behavior was kind of an abuse of keypress in the first place), but I'm filing a bug anyway because it might not be, and if it is, I'd like some confirmation that this behavior is indeed changing.
Comment 1 Eric Naeseth 2007-12-13 17:18:28 PST
Fixing a bit of grammar in the title.
Comment 2 Eric Naeseth 2007-12-13 17:25:05 PST
I don't know a whole lot about Bugzilla or how you guys are using it, but it looks like if this really was unintentional then it would count as a regression, so I'm adding a keyword to that effect.
Comment 3 Alexey Proskuryakov 2007-12-13 23:28:33 PST
Yes, this was intentional, see <http://lists.webkit.org/pipermail/webkit-dev/2007-December/002992.html>.

As with any change, we are open to reconsidering this if it causes too much trouble, but for now, I'm closing as INVALID. Thank you for filing this bug, we appreciate your help!
Comment 4 Eric Naeseth 2007-12-14 07:48:45 PST
Thank you very much for that link.

If I find any *real* regressions, I'll try to let you all know. :)
Comment 5 Mark Rowe (bdash) 2008-03-19 01:53:36 PDT
*** Bug 17937 has been marked as a duplicate of this bug. ***
Comment 6 Mark Rowe (bdash) 2008-03-19 10:17:54 PDT
*** Bug 17947 has been marked as a duplicate of this bug. ***
Comment 7 Alexey Proskuryakov 2009-09-04 13:58:05 PDT
*** Bug 28905 has been marked as a duplicate of this bug. ***