Bug 164221 - [GTK] Crash of the application on an X error
Summary: [GTK] Crash of the application on an X error
Status: RESOLVED DUPLICATE of bug 164303
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Critical
Assignee: Nobody
Depends on:
Reported: 2016-10-31 06:22 PDT by Milan Crha
Modified: 2016-11-02 07:56 PDT (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Milan Crha 2016-10-31 06:22:52 PDT
From https://bugzilla.gnome.org/show_bug.cgi?id=773302#c15

I have a reproducer, reliable (here), where the evolution crashes in an X error with the below backtrace. My steps are unusual for regular users, but maybe it'll shed some light on the issue.

I run evolution under gdb and press Ctrl+C do set my breakpoints and so on after it is loaded. As soon as do that I get the crash of the evolution as shown below. The backtrace mentions "WebKit::WebPageProxy::processDidCrash()", thus it looked like the WebKitWebPorcess crashed for some reason, thus I re-tried and I first attached another gdb to the running WebKitWebProcess and then repeated the Ctrl+C thing. It surprised me that the gdb of the WebKitWebProcess stopped too in the gdb prompt. I issues "c" command and everything went as it should. From that it seems to me that you pass really everything to the WebKitWebProcess, including the Ctrl+C, which just stops (crashes) the process when there is nothing on top of it, like gdb, which handles the interrupt request.

The backtrace on the evolution side with webkitgtk4-2.14.1-2.fc25.x86_64 (I'm sorry, no debug info for webkitgtk+, too large, but the steps should be better than the backtrace, I hope):

#0  0x00007ffff2aebe40 in gdk_x_error () at /lib64/libgdk-3.so.0
#1  0x00007fffef773ded in _XError () at /lib64/libX11.so.6
#2  0x00007fffef770d17 in handle_error () at /lib64/libX11.so.6
#3  0x00007fffef770dd5 in handle_response () at /lib64/libX11.so.6
#4  0x00007fffef771ce8 in _XReply () at /lib64/libX11.so.6
#5  0x00007fffef76d6dd in XSync () at /lib64/libX11.so.6
#6  0x00007fffef76d77b in _XSyncFunction () at /lib64/libX11.so.6
#7  0x00007ffff3fb4b7c in WebKit::AcceleratedBackingStoreX11::update(WebKit::LayerTreeContext const&) () at /lib64/libwebkit2gtk-4.0.so.37
#8  0x00007ffff3f9c2c1 in webkitWebViewBasePageClosed(_WebKitWebViewBase*) [clone .localalias.174] () at /lib64/libwebkit2gtk-4.0.so.37
#9  0x00007ffff3f5c08b in WebKit::AcceleratedDrawingAreaProxy::exitAcceleratedCompositingMode() () at /lib64/libwebkit2gtk-4.0.so.37
#10 0x00007ffff3f5c0fc in WebKit::AcceleratedDrawingAreaProxy::~AcceleratedDrawingAreaProxy() () at /lib64/libwebkit2gtk-4.0.so.37
#11 0x00007ffff3f5db49 in WebKit::DrawingAreaProxyImpl::~DrawingAreaProxyImpl() () at /lib64/libwebkit2gtk-4.0.so.37
#12 0x00007ffff3dab328 in WebKit::WebPageProxy::resetState(WebKit::WebPageProxy::ResetStateReason) () at /lib64/libwebkit2gtk-4.0.so.37
#13 0x00007ffff3dabd9e in WebKit::WebPageProxy::resetStateAfterProcessExited() () at /lib64/libwebkit2gtk-4.0.so.37
#14 0x00007ffff3dac803 in WebKit::WebPageProxy::processDidCrash() () at /lib64/libwebkit2gtk-4.0.so.37
#15 0x00007ffff3dd7139 in WebKit::WebProcessProxy::didClose(IPC::Connection&) () at /lib64/libwebkit2gtk-4.0.so.37
#16 0x00007fffec9e28dd in WTF::RunLoop::performWork() () at /lib64/libjavascriptcoregtk-4.0.so.18
#17 0x00007fffeca092b9 in WTF::RunLoop::RunLoop()::{lambda(void*)#1}::_FUN(void*) () at /lib64/libjavascriptcoregtk-4.0.so.18
#18 0x00007ffff5f5ee42 in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#19 0x00007ffff5f5f1c0 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#20 0x00007ffff5f5f4e2 in g_main_loop_run () at /lib64/libglib-2.0.so.0
#21 0x00007ffff6a362e5 in gtk_main () at /lib64/libgtk-3.so.0
#22 0x0000000000404c60 in main (argc=1, argv=0x7fffffffdca8) at main.c:659
Comment 1 Carlos Garcia Campos 2016-11-02 07:56:36 PDT

*** This bug has been marked as a duplicate of bug 164303 ***